Separate tool duplicates objects
Closed, ResolvedPublic

Description

As soon as you apply Separate (P) in edit mode on a mesh, and you tweak the operation from the tool shelf, it keeps creating more and more objects.

In the file provided, there is only one mesh, consisting of three separate spheres. All you have to do is press P for Separate, and after that, keep switching from 'By loose parts' to 'By Material' several times. The more times you do it, the more objects are created. Go to object mode and check how many objects are created.

Regards.

Pep.

Details

Type
Bug

Think issue is caused by global vs. local undo stacks. There are several known limitations of it. Maybe the simpliest solution for now would be to disable operator redo for such kind of operators?

Yes, I think best solution is to disable redo for this operator, there isn't any good way to solve this now without major refactoring.

Disabled in svn rev42463. More user-friendly solution would lead to more global refactoring of unto system.
Thanks for the report, closing it now.

Sergey Sharybin (sergey) closed this task as "Resolved".Dec 6 2011, 3:36 PM