Page MenuHome

Crash when border rendering in sequencer. (Not Cycles related)
Closed, ResolvedPublic

Description

If I have a 3d scene in the VSE and I make a border that is smaller then the original render size then blender crashes on rendering. (Ubuntu sometimes scrambles the image rather then crashes.)
Simply press f12 in the attached file and blender will crash.
However if you select the crop option then everything works fine.

Tested on Blender 2.61 official (Ubuntu) and http://builder.blender.org/download/ rev 43090 (win 64)
Windows 7 64bit and Ubuntu 11.04 32 bit.
4GB ram
NVIDIA Quadro 1600M
T9500 Core 2 Duo @ 2.6 GHz.

Details

Type
Bug

Event Timeline

Got patch for this, but maybe there's nicer way so prefer somebody to review before commit.

Patch looks ok. There may be a nicer solution but it seems like that would require a lot of refactoring related to how render results are allocated, so this is ok for a bugfix.

Fixed in svn rev43130. Thanks for the report, closing.

Sergey Sharybin (sergey) closed this task as Resolved.Jan 4 2012, 4:28 PM

I am having this problem with 2.77a on Windows 10.

Sometimes crashing Blender, sometimes just coming up with a garbled mess. This happens where the VSE only contains a single video.

@Mike Futcher (yogyog), please open a new report with a simple .blend and steps to reproduce the problem. It's likely a different issue because the original report does not involve a video but a 3d scene, and lots of things have changed in the 4 years since this original report.