Page MenuHome

Blender: Layer Move Animation Bug? Keyframed as Layer 1, comes out as Layers 1 AND 2.
Closed, ArchivedPublic

Description

1) Go to frame 1, keyframe the Layers for the object onto layer 1.
2) Go to frame 2, click on layer 2 (the object disappears), and keyframe that.
3) Go to frame 3, click layer 1, keyframe that.
4) Now when we go back to frame 2 the object is on both layer 1 and 2 (!).

Further odd behavior is visible if you click a second time on frame 2: the second click causes the layers to work correctly.
If you look at the Animation Curves, they are correct, and scrubbing through the list there correctly updates the 3D Viewport
If you LMB+Drag on the timeline, it updates the 3D Viewport correctly (but not when you simply LMB click on a frame--see above).

Here is a video of the behavior that has the demo:
http://www.youtube.com/watch?v=DJQ6zK5xQyU

I included a .blend, but this is very easy to replicate. So far we have done so on:
* Official 2.61 (OS Unknown)
* SVN version 2.61 (sub 2), r43365. Release - build date: 2012-01-14, 09:08:48 (Linux)
* graphicall.org build 2.61.1, r43283 (Windows)

Details

Type
To Do

Event Timeline

This has probably to do with the fact that an object cannot be on no layer at all,
so, when switching frames, the removal of layer 1 is unsuccessful, but layer 2 is added.
A workaround is therefore obvious, have the object on some unrelated layer (or have it
on layer 2 the whole time, if you just want to remove it from 1).

Removing this restriction would probably be possible (I have not looked at the code),
but I don't know if it's worthwhile if it turns out to be complicated.

David, yes, that workaround works for me.

Issue is indeed caused by curves applying one-by one and even if overall state on frame 2 is correct, it can't be reached because first curve is trying to make object to belong to no layers. Currently there's no nice way to resolve such restriction. Added not to our TODO wiki (http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Animation). Thanks for the report, but will close it now.

Sergey Sharybin (sergey) closed this task as Archived.Jan 18 2012, 6:32 PM