Page MenuHome

OpenAL 3D Audio: Stereo Panning does not work, Sounds like Mono
Closed, ResolvedPublic

Description

3D sounds from speaker objects are playing back like mono sounds in 2.62. No stereo panning happens. The output of left speaker’s volume is also a little louder than right’s. To test it mute speaker objects one by one and play animation. If the left speaker object is muted, right speaker object plays sound but I hear that on left speaker and sounds like mono.

This problem happens only if audio device is set to default OpenAL device. SDL device is playing back correctly. Previous versions of Blender don’t have this problem with same file.

Another guy also reported same problem on BA: http://blenderartists.org/forum/showthread.php?245982-2.62-Audio-Problems

Blend file included. Though I haven’t uploaded mono sound files.

System Info:
Blender-Build: Official Blender 2.62 Release Windows 64
OS: Win 7 (64 bit), SP 1
RAM: 2 GB
CPU: Intel Core 2 Duo @ 2.53 GHz

Details

Type
Bug

Event Timeline

Joerg, can you please check this? Thanks!

That was issue with openal-soft libraries. Reverted back to creative openal. Hopefully it wouldn't lead to crashes caused by ffmpeg+openal (originally libraries were upgraded to try to resolve this crashes, but finally were totally solved by changes in FFmpeg configuration).
Thanks for the report, closing it now.

Sergey Sharybin (sergey) closed this task as Resolved.Feb 17 2012, 6:51 PM