Page MenuHome

Degenerated triangles from BMesh + Difference
Closed, ResolvedPublic

Description

In the attached file, using a BMesh Freestyle build (e.g. http://graphicall.org/170), the Booelean Difference operation between objects 'Diagonal' and 'bVert' (on layer alt-3) results in a mesh that contains a degenerated triangle around the place where the two meshes intersect. The problem does not go away if you apply the modifiers to create a simple mesh object.

This is relevant when using the Freestyle builds, because it results in hidden lines becoming visible. Without BMesh, the same boolean operation gives a clean mesh without degenerated triangles.

There is now a workaround within Freestyle, but it would be nice to get rid of the root cause.

Details

Type
Bug

Event Timeline

Sorry, this should be in the BMesh tracker. Hadn't realised that there was one. Please move it, if possible (I don't seem to be able to).

Hopefully the issue was fixed in svn rev44548. Thanks for the report, closing.

Sergey Sharybin (sergey) closed this task as Resolved.Feb 29 2012, 2:49 PM

I needed to revert that commit, which was more like a workaround.

Basically boolean operation is not the only way to generate zero-area face, it could also happen with character animation and it's indeed better be solved from freestule side.
Having that workaround solved particular case of failed rendering, but it introduced quite enough other limitations, like some failures of recursive fracture.

If it's still an issue for you, please contact freestyle developers (this project is not in trunk yet and not officially supported by this bugtracker).