Page MenuHome

2.62 Torus Batch building "Bug" or A Experimental Feature?
Closed, ResolvedPublic

Description

OS: Win7 64bit | Blender: 2.62

I don't know if this is a bug, but when activating more than one visible layers, you build a torus, then it would be built among each layer, other object types are not like this. Hmm.... If this is not a bug, then some inspiration here :P e.g.:

Sometimes when we really wanna batch build a object among layers, what shall we do? Should it be a better solution to holding some keys (like SHIFT) while adding new objects? So, I bet this should be a new feature better than a bug :)

See attachment
FYI.

Details

Type
Bug

Event Timeline

It's not actually feature, just a difference in how python-defined primitives used to behave. Made them behave in the same way as C-defined in svn rev44749.
Thanks for the report, closing it now.

Sergey Sharybin (sergey) closed this task as Resolved.Mar 8 2012, 7:51 PM

Sergey, Thank you for fixing! However, I don't think it works for me, since I still experience it with r44767 and 44768. :(
Win7 64bit

Besides, "Align to View" for Torus doesn't work well either, which is, it can't be switched back, I mean it can't be toggled off. FYI.

Sorry, I don't mean to border in this closed report, I just wonder why it still happens only for Torus, instead of other primaries. There must be something wrong.

Currently tested in 2.66 RC | win7 64

Eeh,, Somehow didn't notice comments earlier =\

Svn rev54639 shall make layers behavior correct :)