Page MenuHome

Framerate goes crazy after changing Sync mode from "Frame Dropping" to "no Sync" while playing anim
Closed, ResolvedPublic

Description

start with default scene.
make sure scene-sync_mode is set to "no sync"
press alt-A
animation should play at 24fps
keep the anim running and change sync_mode to "frame dropping"
the displayed framerate (top-left of 3dview)shows something like 1300 fps although the frame cursor seems to go at good framerate.
now (the animation should still be looping), switch sync_mode to "no sync" ... it just goes 1200-1300 fps, nearly faster than Buzz Lightyear !
and for the grand finale press alt-A to stop the animation, and again alt-a to restart, and voila, its back to a normal fps

if No Sync is supposed to be really no sync, and just run as many frames as the gfx card allows, why is it doing normal framerate by default?
there seems to be something wrong in some behavior.

Details

Type
Bug

Event Timeline

The issue appears to be with the way the timer is used in sync mode. In screen_animation_step, wt->duration is modified, which causes the timer to continuously fire.

So this is my current workaround: http://www.pasteall.org/30135/diff

I know a static local variable is not the best solution, especially when we will ever be able to have different playback timers in different windows, but it works for now?! The problem is I don't know where else to save the value meanwhile; suggestions?

Fixed in r44979. Closing.

Joerg Mueller (nexyon) closed this task as Resolved.Mar 18 2012, 11:21 PM