Page MenuHome

Modifiers with use_apply_on_spline = True do not work on curve with shapekeys
Closed, ResolvedPublic

Description

The attached scene has been made by:
- Loading factory defaults
- Removing every object
- Adding a plane mesh, scaled to 5
- Adding a curve path, translated x=0 y=0 z=4, with extrusion=1
- Putting a shrinkwrap modifier on the curve with target the plane
- Adding a shapekey to the curve

Expected behaviour:
The curve handles are projected on the plane.
The strip generated by curve extrusion is intersecting the plane with an angle of 90°

Actual results:
The curve and generated strip stay in place

If I disable use_apply_on_spline, the modifier works (of course one doesn't see much because the generated surface is orthogonal to the plane thus projects onto a line).
If I toggle edit mode on the curve, the modifier temporarily works (I see the expected result while in edit mode)
If I remove the shape key, it also works.

Note that the extrusion is not needed to trigger the bug. It just makes it more visible, and problematic (without extrusion I don't care about use_apply_on_spline being True or not)

Details

Type
Bug

Event Timeline

Fixed in svn rev44921. Thanks for the report, closing.

Sergey Sharybin (sergey) closed this task as Resolved.Mar 16 2012, 12:47 PM