Half of the Display settings from object tab not working for Armature objects / Bones
Closed, ResolvedPublic


(screenshots also attached)

Some Armature / Bone drawing options seem to be not implemented:

Bounds: box --> bbox encloses the first bone only

Type: bounds --> draws like wireframe instead of bbox

Object.show_wire = True won't draw Bones as wireframes, but as solid without orange outline. Bone.show_wire with a custom_shape bone draws wireframe as expected, Object > Display > Wire should do the same

Btw. an Armature object color can be set, but won't show. Color picker could be disabled if not supported.



Bastien, can you look into this?

Ok, so here are my conclusions for now:
* There was simply no boundbox implemented for armatures (the cube is a dummy (-1,-1,-1,1,1,1) one, nothing to see with first bone ;) ). So in attached patch I added a simple one, only enabled in Object mode (i.e. in edit/pose ones, you’ll still get the bones in wireframe, as imho boundbox is stupid in those modes).

* Object.show_wire and color were enabled for all objects, restricted those to only MESH, CURVE, SURFACE, FONT and META, as imho they do not make any sense for the other types!

Will try to get a review (or at least some approval) soon.

From my side, i'm fine with your changes :)

Thank you Bastien!

Committed in svn45084 (aligorith was ok with it too).

Thanks for reporting!

Bastien Montagne (mont29) closed this task as Resolved.Mar 22 2012, 2:30 PM

In Blender 2.63 official, bounding box doesn't seem to work at all. It's not showing anything, not even the dummy cube. Something went wrong with bounding box code?

Nope, it works, afaik… Note that:
*It’s only visible in Object mode
*You must have several unaligned bones (or one bone not aligned with armature axis), else (as bones themselves have no width) you only get a line…

you're right, i was actually getting a thin (z-fightening) line and did not notice it was there. Works as intended.