Cycles texture nodes messed up by image window chooser r45323
Closed, ResolvedPublic

Description

Open provided blend file
From the image editor select the mano.jpg texture
See how the foot geometry changes texture to mano.jpg, even if that's in *another material* that isn't the active one nor is assigned to the selected face's

Details

Type
Bug

Couldn't redo the issue, but I'm not sure this is the right .blend file? It's set to Blender Render, and there is no material assigned to any of the faces, and no mano.jpg is included.

gah, you're right I picked the wrong file, will fix in a few hours

cheers

now uploaded a good file, pick the manga.jpg from the image editor: see foot changing for no reason

Fix in svn, thanks for the example file.

nope, that's not the end of this bug, the problem is selecting images from the image window is changing the texture node itself, and what's worst it does it in a material that isnt even selected. pick manga.jpg again and see how the foot material changes the texture to manga.jpg

Right, forgot to fix the assigning too, should be fixed now.

Brecht Van Lommel (brecht) closed this task as Resolved.Apr 2 2012, 9:39 PM