Page MenuHome

Cycles doesn't work with AMD Juniper GPU, compiller throws errors.
Closed, ResolvedPublic

Description

Using Catalyst 12.3 on Windows 7 x64, i got quite some warnings in console, but 3 errors when i try to run Cycles:

"error: expression must have pointer-to-struct-or-union type".

Of course Cycles doesn't display anything. I'm attaching a text file with the output of the console. Lines 119 to 121 have the description of the problem.

Regards

J.




Details

Type
Bug

Event Timeline

What Blender version do you use? Please always provide all the relevant information as asked by the bug report guidelines (the ones you see when reporting a bug)

Oops sorry, rev. is 45447.

Can you check with latest AMD beta drivers? I am not sure if it's a bug on our side or if the drivers are too "old".
We rely on some fixes from AMD, probably they are not in the official drivers yet.

Catalyst 12.4 beta + OpenCL 1.2 Preview Drivers, as found by Google. Results are the same. I'm not posting log, since is basically the same.

Brecht: I got reports in the forums that it does indeed not work. I asked them to disable Texture support, still the same. Might be a bug in one of the recent commits, because it was confirmed to work about 2 weeks ago. Can you have a look please?

AMD Thread on ba: http://blenderartists.org/forum/showthread.php?249705-Cycles-improvements-on-AMD-with-public-driver-release

Your reported issue has been fixed in SVN. Thanks for taking the
time to report!.

Daniel Genrich (genscher) closed this task as Resolved.Apr 9 2012, 5:35 PM