no pressure with Genius Mousepen i608X tablet
Closed, ResolvedPublic

Description

Hi!

There is no pressure with Genius Mousepen i608X tablet in blender. Nor in sculpting nor in texture painting.
This device works with the evdev driver. (I am using xubuntu 64-bit with a pathed 3.2.0-24 kernel which conatains the driver for this device.)
I figured out how to make the pressure work: I have modified the intern/ghost/intern/GHOST_WindowX11.cpp file.
around line 608 I have coded the following:
instead of this:
if (m_xtablet.StylusDevice == NULL && is_stylus(device_info[i].name, device_type))
I coded this:
if (m_xtablet.StylusDevice == NULL && (is_stylus(device_info[i].name, device_type) || device_info[i].type == XInternAtom(m_display, XI_TABLET, False)))

And of course I modified the tilt code a little bit, since this device does not support tilting in this way:
if (xvi->num_axes > 3) {
m_xtablet.XtiltLevels = xvi->axes[3].max_value;
m_xtablet.YtiltLevels = xvi->axes[4].max_value;
}
else {
m_xtablet.XtiltLevels = 0;
m_xtablet.YtiltLevels = 0;
}
}

May be this is not the best idea to code this in this way, but this is worked for me now I got pressure with my device in both cases.

In my opinion this code may work with other non-wacom tablets wich uses the evdev driver. You can find those tablets list here:
http://sourceforge.net/apps/mediawiki/digimend/index.php?title=Tablet_support_status

I have attached the patch file and my current GHOST_WindowX11.cpp file (because I was not quite sure that I have genereated the patch correctly)

viktorias (Viktoria S.) added a comment.Via Old WorldOct 2 2012, 3:20 PM

Is there any updates on this one?

dingto (Thomas Dinges) added a comment.Via Old WorldJan 23 2013, 3:42 PM

Viktoria, is the issue still present in a new build? (download from http://builder.blender.org/download/)

Could you please check with a new one? Sorry for the delay!

viktorias (Viktoria S.) added a comment.Via Old WorldJan 27 2013, 1:28 PM

Hi!
I have downloaded blender-2.65-r54115-linux-glibc211-x86_64. Now I am using xubuntu 12.10 with 3.5.0-21-generic kernel which has the kernel driver for this pen. And the issue is still present.

Moved from Blender 2.6 Bug Tracker to Patches

applied r54454.
in future, if you have a fix best post in the patch tracker.

campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldFeb 11 2013, 9:18 AM
viktorias (Viktoria S.) added a comment.Via Old WorldFeb 12 2013, 9:50 AM

Hi!

I have downloaded blender-2.65-r54482-linux-glibc211-x86_64 from the buildbot, and everything works fine :).
Thank you everybody.

Thanks for the patch! great when users can provide own fixes :)

i have windows and a genius tablet, it don't work in blender but it work in other programs like zbrush or mudbox

Add Comment