Strange behavior of 'Auto IK'
Closed, InvalidPublic


Blender 2.63

Just open the file I attached, when you grab the bone named 'C', it doesn't stay in place on RMB clic.
'Auto Ik' doesn't seem to work in this situation.


kiopaa (kiopaa) set Type to Bug.Via Old WorldJun 18 2012, 8:38 AM
Sergey Sharybin (sergey) added a comment.Via Old WorldJun 18 2012, 12:49 PM

Bastien, AFAIR you're now pretty familiar with armatures code, can you please look into this? Thanks!

Bastien Montagne (mont29) added a comment.Via Old WorldJun 18 2012, 1:40 PM

Gaaah… *Why* people are using constraints with bones?!? xD

So it’s another problem caused by the ChildOf constraint… Will see if I find something in the code, but once again, I fear we are facing a limitation in our current transform system. To be honest, this case is really complex (transform of bones on its own is, but if you add IK *and* constraints…).

In fact, I I think I remember that IK simply means that all other constraints are ignored. In this case, it would mean the temp auto IK transform is simply computed without the ChildOf constraint, hence this one adds its effect after validation of the transform operation. If this is the case, it’s definitively a limitation, we can’t do anything imho.

kiopaa (kiopaa) added a comment.Via Old WorldJun 18 2012, 5:19 PM

Hi Bastien,

No I don't think the problem is caused by the ChilfOf constraint.
I try to replace this constraint by a 'CopyRot' and the strange behaviour remains.

Bon courage !

Bastien Montagne (mont29) added a comment.Via Old WorldJun 18 2012, 6:26 PM

Hi Pascal,

I think this enforces my last comment: you just can't expect an exact transform when using both autoIK and constraints on a same chain.

Using AutoIK option is exactly the same as adding a target-less IK constraint to your C bone. It just won't work correctly if you have other constraints in your IK chain (IK has its own, quite limited, constraint system…).

Assigning to Joshua to see what he thinks, but I’m pretty sure we can’t do much here…

kiopaa (kiopaa) added a comment.Via Old WorldJun 18 2012, 7:22 PM

Hi Bastien,

It seems to me that constraints aren't the problem here. I made a new blendfile.

download from here :

There is only a three bones chain, **no constraint at all**. AutoIK is on.
When you grab one bone of the chain, all goes wrong.

Why ? I scaled the first bone of the chain with different factors on each axis.

Ton Roosendaal (ton) added a comment.Via Old WorldOct 23 2012, 7:31 PM

Auto-IK is not capable of handling such situations. Non-uniform scales of bones should be avoided at all costs, that's quite common for rigging.

I can make a todo item for a math genius who can make IK warp back in non-uniform space... but that's a nightmare, and not very rewarding work - since it's easy to avoid.

Ton Roosendaal (ton) closed this task as "Invalid".Via Old WorldOct 23 2012, 7:31 PM

Add Comment