Home

no UI for 'clear Object Motion paths'
Closed, ResolvedPublic

Description
I can create, update but not remove an object motion path through the UI
(also, shouldn't it be Motion Path instead of Paths?)

thanks
lichtwerk (Philipp Oeser) added a comment.Via Old WorldJun 21 2012, 10:16 PM
"Clear Paths" is actually available in the toolbar object tools - which will clear all selected paths.
Dont know the design decision behind this and looking at http://aligorith.blogspot.de/2012/05/motion-paths-gui-cleanup.html doesnt really mention this issue.
Would make sense to have a button in propertiy editor as well though it would have to work on active (vs. all selected) then, right?

"Motion Paths" vs. "Paths": no strong opinion on that (maybe that was just chosen to save some space?)
sergey (Sergey Sharybin) added a comment.Via Old WorldJun 22 2012, 9:32 AM
Thomas, what our UI mafia would say on that?

Just note from me: i don't feel nice adding extra button to properties region, this sounds like duplicated functionality. I'd say it's more matter of making better documentation on this,
lichtwerk (Philipp Oeser) added a comment.Via Old WorldJun 28 2012, 1:30 AM
OK, I've attached a patch with following changes (still think the bugreport has a point):

- adds a button "Clear Paths" to the Property Editor
- makes both operators "OBJECT_OT_paths_clear" and "OBJECT_OT_paths_update" functionality aware of where it was called from
so when they are called from the Properties Editor they will only operate on the object in this context (and not on all selected)
note: an object might also be pinned in the Property Editor and with this patch it is made sure that the op will operator on THIS pinned object
(which doesnt even need to be selected)
- (also a little change to the panels layout which admittetly "wastes" a little space but groups the settings what to show - this might be debatable...)
- tooltip might need a better phrase
- left the motion path ops relating to bones untouched (they are in the armature context - not a single bone - so should be fine like this?)
- ... style is a little clumsy / some duplicated code (see comments in patch) ...
aligorith (Joshua Leung) added a comment.Via Old WorldOct 4 2012, 1:09 PM
Fixed a duplicate of this bug. On second thought, it does make sense to have one of these buttons in the properties editor, since users seem to want to look there for this.
aligorith (Joshua Leung) closed this task as "Resolved".Via Old WorldOct 4 2012, 1:09 PM
dingto (Thomas Dinges) added a comment.Via Old WorldOct 4 2012, 1:09 PM
This has been fixed in SVN 51036.

Add Comment