UV Unwrap Ignores Aspect Ratio Setting
Closed, ResolvedPublic

Description

Looks like the "Correct Aspect" switch when using unwrap is completely ignored. Results are always the same. Shouldn't switching it off mean that the whole UV space gets covered, regardless of the aspect ratio of the unwrapped geometry / image?

Steffen Dünner (debris) set Type to Bug.Via Old WorldJun 29 2012, 1:04 PM
Sergey Sharybin (sergey) added a comment.Via Old WorldJul 2 2012, 12:15 PM

Antony, could you please check on this? Thanks!

BTW, closed duplicate report http://projects.blender.org/tracker/index.php?func=detail&aid=31979&group_id=9&atid=498

Antony Riakiotakis (psy-fi) added a comment.Via Old WorldJul 2 2012, 1:12 PM

Hi,

First of all, a few things to note: Correct Aspect has to do with the ratio of the image, so for square images, it won't have any effect at all. For non square images it accounts for the fact that unwrapping is done to a square target space and actually modifies the UV coordinates by the aspect ratio of the image to avoid any stretching introduced by mapping a square space to a rectangular one.

This looks like it's working like it should on latest trunk. If there's a case where it doesn't could you please post a file/image that fails?

Tobias Oelgarte (niabot) added a comment.Via Old WorldJul 3 2012, 12:55 PM

I did some more experiments and i believe i found the issue. The aspect ratio might be stored for the first initial unwrap, but it is not updated for further unwraps on different textures (aspect ratios). I will give an example:

1. You create a texture with 512x512 px (1:1 ratio) and unwrap the mesh. Now the ratio gets stored for the UV-Layer as 1:1.

2. Now you exchange the texture. Either loading a different image (replace) on same slot or change to a different image slot. If this texture has not the same ratio (for example 1024x512 px, which is 2:1) then the aspect option will fail since it still assumes a 1:1 ratio, not updating to the ratio of the currently chosen texture.

Antony Riakiotakis (psy-fi) added a comment.Via Old WorldJul 5 2012, 3:59 AM

Indeed I can confirm that aspect ratio correction is only done on unwrap. I can hook up a mechanism to adjust the aspect ratio of uvs on image change.

Antony Riakiotakis (psy-fi) added a comment.Via Old WorldJul 9 2012, 6:13 PM

Can you test again after revision 48760?

Brecht Van Lommel (brecht) added a comment.Via Old WorldSep 4 2012, 1:38 PM

No reply, let's assume this was fixed.

Brecht Van Lommel (brecht) closed this task as "Resolved".Via Old WorldSep 4 2012, 1:38 PM
Antony Riakiotakis (psy-fi) added a comment.Via Old WorldSep 4 2012, 1:42 PM

The fix was mostly reverted by Campbel, see r49633 and ensuing discussion in cvs mailling list. It needs a better way to expose the feature.

Add Comment