Page MenuHome

Limits on Proxy-Bones are not copied for bones created in original file after proxy creation
Closed, ArchivedPublic

Description

Duplicates: T28230

Systeminfo: Win 7 64bit, NVIDIA GTX 560ti, Blender 2.63a

Using a proxy of an armature that is part of a group, transform limits of bones in pose mode are correctly set in the proxy. After adding new bones with transform limits to the armature in the original file, the new bones are there in the proxy instance but their transform limits are not.

Steps to reproduce:
1. New File with defaultcube
2. Add Armature->Single Bone
3. In Objectmode: Make a group of the default cube and the armature
4. In Posemode: Parent the cube to the bone.
5. In Posemode: Set transform limit on the bone, e.g. lock x-Rotation
6. Save file A.blend.
7. New File
8. Link the group into that file.
9. Create Group instance.
10. Make Proxy of armature.
11. In Pose-Mode: Check transform limit for Bone: It's there.
12. Save file B.blend.
13. Open file A.blend.
14. In Edit mode add another bone to the armature.
15. In Pose-mode set some limits to the transformations of the newly created bone: e.g. lock x.Rotation.
16. Save file A.blend.
17. Open file B.blend: The new Bone is there.
18. In Pose-Mode: Check transform limits for the new bone: They are not there.

"Copying" the transform limits of bones in the initial creation of the proxy but not when updating the proxy is inconsistent and not expected. To me this is a bug. The "duplicate" #28230 I specified mentions the same problem but I think the fix got side tracked because of locked layers. No locked layers are needed to reproduce this.

Details

Type
To Do

Event Timeline

The proxy system is not in development currently. I've made a todo item for this issue in wiki:
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Rigging

The system hasn't been upgraded since 2007 even! It's really urgent, we all know that. But it needs a very competent team or developer + plenty of time.

Ton Roosendaal (ton) closed this task as Archived.Jul 22 2012, 2:38 PM