Home

Segfault randomly when selecting object
Closed, InvalidPublic

Description
Using Blender 2.63 from official site.
Linux Fedora 16 x64 up to date (kernel 3.4.4-4)
ATI Mobility Radeon HD 5400 Series

Using blender, selecting an object and crashes. This crashes lot of tiime (10 times per hour of work) only on edition, not in render process.

I used GDB to create a core dump. It is 510Mo so I dont send it, but this is what I can output:

(gdb) core-file trace.log
[New LWP 8015]
[New LWP 16812]
[New LWP 16811]
[New LWP 16810]
[New LWP 16380]
[New LWP 16376]
[New LWP 16371]
[New LWP 16370]
[New LWP 16369]
[New LWP 16337]
[New LWP 16327]
Core was generated by `/home/patachou/Téléchargements/blender-2.63-linux-glibc27-x86_64/blender'.
Program terminated with signal 11, Segmentation fault.
#0 0x00007ffff69667bd in nanosleep () at ../sysdeps/unix/syscall-template.S:82
82 T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
(gdb) bt
#0 0x00007ffff69667bd in nanosleep () at ../sysdeps/unix/syscall-template.S:82
#1 0x00007ffff6993b64 in usleep (useconds=<optimized out>) at ../sysdeps/unix/sysv/linux/usleep.c:33
#2 0x00000000016bb86e in AUD_OpenALDevice::updateStreams() ()
#3 0x00000000016bb939 in AUD_openalRunThread(void*) ()
#4 0x00007ffff620cd90 in start_thread (arg=0x7fffe93fe700) at pthread_create.c:309
#5 0x00007ffff6999f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
(gdb)

It seems that nanosleep and thread creation crashes... Is there a way to avoid this ? Is is a Blender Bug or specific to my distribution ? hardware ?

Thanks
metal3d (FERLET Patrice) set Type to Bug.Via Old WorldJul 27 2012, 2:59 AM
sergey (Sergey Sharybin) added a comment.Via Old WorldJul 27 2012, 10:29 AM
If crash happens in stuff like nanosleep (or other functions from libc) it's likely some really bad memory corruption. The issue with crash on object selection is most likely caused by video driver glitch, so please try using blender-softwaregl from our site. If blender wouldn't crash that would mean you need to forward report to ati driver developers.

You could also try using 2.64testbuild1 from http://download.blender.org/release/Blender2.64/ There were some fixes which could have been resolved your issue.

P.S. Updated topic to be a bit more clear, helps when you're browsing bugs.
metal3d (FERLET Patrice) added a comment.Via Old WorldJul 27 2012, 1:16 PM
That's right that ATI sucks on my laptop... fglrx crashes Blende, and now with radeon (free) driver I have this problem. So, I'm currently trying the softwaregl binary (I don't know what that changes, peformances seems to be the same...) and I'll tell you.

I'll ty 2.64 later.

Thanks for your answer :)
metal3d (FERLET Patrice) added a comment.Via Old WorldJul 27 2012, 2:41 PM
Ok, I see. blender-softwaregl is statically linked to your libGL etc... That works for now. No crashes, no problem. It's the workaround I can use.

I will contact ATI driver developpers. Thanks again.
sergey (Sergey Sharybin) added a comment.Via Old WorldJul 27 2012, 3:52 PM
Well, cool to hear you could work in blender now, but it's sad to hear ati is still buggy.

Anyway, thanks for the report! :)
sergey (Sergey Sharybin) closed this task as "Invalid".Via Old WorldJul 27 2012, 3:52 PM
metal3d (FERLET Patrice) added a comment.Via Old WorldAug 5 2012, 10:28 AM
Just a little comment to say that in Fedora 17 the problem seems to be fixed !
sergey (Sergey Sharybin) added a comment.Via Old WorldAug 5 2012, 10:38 AM
Cool to hear this. Let's hope they wouldn't break it again :)

Add Comment