Edit Mode performance with particle System
Closed, InvalidPublic

Description

In a current scene, I have an emmiter and some hair on it, with two particle systems.
When I enter edit mode, the particle hair is hidden, but the editing performance is awful. As soon as I disable the particle system display in the modifier stack, everything is fine, though nothing changes (particles are already hidden in editmode)
I guess the particles are already calculated, while not seen, but I think this should be delayed to the exit of editmode, to allow better editing performance.

Sergey Sharybin (sergey) added a comment.Via Old WorldJul 27 2012, 7:08 PM

Please always attach minimal .blend files which demonstrates the issue. This saves lots of time troubleshooting the issues.

Aaron Symons (wet_sponge) added a comment.Via Old WorldJul 28 2012, 1:47 PM

What version and revision of Blender are you using, and what OS?

I just tried with 20,000 hair particles, which slowed down performance in object mode. Going into edit mode increased performance for me. I'm using the official release (2.63a).

Performance, as well as other things, can vary if you're using an SVN build from GraphicAll, as these are usually a work-in-progress build.

Sergey Sharybin (sergey) added a comment.Via Old WorldJul 28 2012, 2:35 PM

It'll always help to know if there're regressions in builds of current trunk, but i would recommend using builds from http://builder.blender.org/download/ which are really close to release builds.

Sorry, forgot these details, I use latest official build 2.63a, from blender.org on Win7 64Bit, My pc has an old intel core2quad /q6700) and a geforce 9800 Gt card


Here's a blend with some particles and children. In object mode there is a lot of lag on my pc, and it slightly improves in editmode, but still far from "interactive" :(
(Upload to pasteall failed, but the blend contained just a sphere with two particle hair systems 2nd 8000 particles first 1000 [default], both interpolated children enabled)

My suggestion was to delay the particle recalculation to the point when edtmode is left, so that it runs smooth, when editing the emitter mesh. If I hide the particle systems in the modifier stack, it runs perfect!

Sergey Sharybin (sergey) added a comment.Via Old WorldAug 2 2012, 12:29 PM

There's no file attached here. Make sure it's less than 5mb. You could also use ftp://download.blender.org/incoming for larger files.

Sergey Sharybin (sergey) added a comment.Via Old WorldAug 5 2012, 7:50 PM

No response for needed sample file which is missed in couple of weeks. Closing the report until requested file is provided. As soon as we'll have that files the report would be reopened.

Sergey Sharybin (sergey) closed this task as "Invalid".Via Old WorldAug 5 2012, 7:50 PM

I cannot attach my blend, because they're quickly getting >5mb with so many particles. (and I don't know how this ftp thing works, sorry)

But you can easily try it out, its a 1 minute setup

Just take the cube, add in a particle system, set it to hair, and set the number to 80 000 (maybe more if there isn't enough lag, i have a fairly old machine.)

In object mode it is now really slow, which is normal (as there are so many particles).
then enter edit mode, and you can move the camera smoothly. But as soon as you move one vertex it lags VERY much.
If you disable the particle system from view (while still in edit mode, as shown in the attached picture)
nothing changes, because the hair is already hidden automatically in edit mode.

but with that hidden, vertex move perfectly fast. (just as if there wasnt hair at all)

I think it's so slow, because the hair is always calculated in the background while in edit mode.

so again, My suggestion was to delay the particle recalculation to the point when editmode is left, so that it runs smooth, when editing the emitter mesh. (just a cube in this case)

attaching the image failed multiple times, I now added it to pasteall
http://www.pasteall.org/pic/36930

Add Comment