Holdout Error with CUDA Cycles Render
Closed, ResolvedPublic


When using Cycles Render with the supported GPU functionality (CUDA, not OpenGL), the holdout shader renders black instead of transparent. Switching to CPU compute removes the issue.

Build: 2.64 test build
OS: Ubuntu 12.04 x86_64
GPU: EVGA GTX 560 ti with most recent driver and CUDA toolkit

(This bug may be identical or related to 32205)

Patton Doyle (pdoyle) set Type to Bug.Via Old WorldJul 31 2012, 4:33 AM
Sergey Sharybin (sergey) added a comment.Via Old WorldAug 1 2012, 3:02 PM

Please always attach simple file which demonstrates the issue -- it'll help testing and checking if we're reproducing the same issue you've got.

I've commited fix for report 32205 which could potentially resolve your issue. Please use builds newer than svn rev49446 (would be available soon here http://builder.blender.org/download/) and see if you still have got the issue. If so, please provide sample file :)

Sergey Sharybin (sergey) added a comment.Via Old WorldAug 2 2012, 5:18 PM

Was able to make tests using GTX580. I didn't have artifacts like horizontal lines, i had completely black areas instead. Now it works properly.
I believe your issue is fixed, so would currently mark the report as solved. If you'll still have bugs in this area please attach sample file which fails for you.

Sergey Sharybin (sergey) closed this task as "Resolved".Via Old WorldAug 2 2012, 5:18 PM
Patton Doyle (pdoyle) added a comment.Via Old WorldAug 2 2012, 6:52 PM

Sorry for the delay, and for the lack of a simple *.blend example. I couldn't get my example to upload.

I tested one of the newer builds (rev49494) and the problem is resolved. Thanks for dealing with it so quickly! :)

Add Comment