Home

Node Texture - Node Material - GLSL Viewport rendering issue
Closed, ResolvedPublic

Description
When having any texture go through a noded Material, the Object in the textured viewport will not display the correct alpha/color/texture.

Also, while editing(anything material/tex wise) with the viewport on GLSL, with that texture/material, it may crash.
(Note: this is Blender Internal, not cycles; I do not know if this happens in Cycles)

Should be all Blender versions, but for reference;

Blender 2.63.17, r49522
OS: Win7 x64
ATI Radeon HD 4200 (integrated graphics)

If you want to do the bug on you're own;

|LONG INSTRUCTIONS(don't use these)| : http://www.pasteall.org/34409/text - Note; uncheck the Texture under the Tex. Tab under properties as well; it'll mess it up

Short instructions(use these):

1)Start up in the Factory-defaults
2)Make the Material into a node material
3)Make the Mat. Node into an Extended Mat. Node,with the original material selected
4)Make a texture which uses nodes, and add it to the Mat. Node setup; And uncheck it in the Tex tab to keep it from overriding the node setup.
5)Connect the Value to Alpha, and Color to Color of the Ext. Mat. Node.
6)Change the Viewport-Shading under the Properties tab of the 3D view to GLSL, and change the viewport shading to "Textured"

Cube should be invisible in the viewport, but should render out just fine; this does the same with Generated tex's, as well as Image tex's.

Now, under the node setup, play with the connections from the Tex. Node and the Mat. node. If you undo the alpha, you can see black; if you undo the color and alpha, you can see the diffuse color, and if you only undo the color, you'll see a tint of the diffuse color.

The first .blend is one with the image texture(have no idea why the UV's aren't working), the second is what you get when you follow the instructions; third is an image of the setup/problem. Sorry if this report is not comprehensible, ask for details below. Thank you for you're time! (And sorry it's so long! :3)
Initial issue about using texture nodes in glsl preview doesn't seems to be a bug -- it's seems simply not implemented feature. Some crashes could be caused by having texture preview widget opened at the time you're editing nodes. It's known crap which goes deep to texture nodes design. To prevent that kind of crashes texture nodes should be rewritten from scratch, but new renderer is becoming production-ready so not sure if it makes sense to spend time re-writting the texture ndoes.

But your file allowed to discover bad bug in glsl shading -- at some points freed memory would be tried to be used. This happens because GPU_link() frees given link, but in some cases the same link would be used in other areas. Attaching valgrind.txt and patch which seems to be working, but would want somebody more familiar with this code to check this.
mtc120 (Michael Chappell) added a comment.Via Old WorldAug 13 2012, 12:10 AM
I see. So I'm guessing it's going to be a while 'till the tex. nodes are rewritten due to it's low priority?

And I'm glad that I'd reported at least one *real* bug. Thanks for the answers!
sergey (Sergey Sharybin) added a comment.Via Old WorldSep 3 2012, 3:18 PM
I've commited patch to the svn. Should work fine now. All the remained stuff is a TODO, or maybe WontFix due to some possible smarter system development.

Thanks for the report, closing now.
sergey (Sergey Sharybin) closed this task as "Resolved".Via Old WorldSep 3 2012, 3:18 PM

Add Comment