Consistent hang when entering edit mode with attached file, OS X PPC
Closed, InvalidPublic

Description

OS X 10.5.8 PowerBook G4 / Mobility Radeon 9700 / SVN 49626 + official 2.63a (46461)

The attached file (old_new_18.blend) was saved on an Intel MacBook Pro with the official 2.64 test release 2 (http://download.blender.org/release/Blender2.64/blender-2.64-testbuild2-OSX_10.6_x86_64.zip) - there are no problems with the file on this platform.


When this file is moved to a PowerBook G4, I get consistent, repeatable hangs every time I try to enter edit mode on any mesh in the file.

To repeat on the PPC platform:

(1) Open attached blend file
(2) A mesh is already selected, press tab to enter edit mode
(3) Hang

I see the same behaviour with the official 2.63a release (46461), and with my own compile of 49626.


With earlier versions of this blend file, which were created and saved using the official 2.64 test release 1 on the Intel platform, I have no problems with on the PPC platform.


Sergey Sharybin (sergey) added a comment.Via Old WorldAug 12 2012, 3:36 PM

Doesn't happen on linux, probably something system-specific.

Jens, could you please check if this happens on OSX for you?

Sergey Sharybin (sergey) added a comment.Via Old WorldAug 12 2012, 3:55 PM

Jens, discussed with Ton -- PPC is not officially supported by Blender anymore. If you wouldn't be able to reproduce the issue on non-PPC station move the issue to TODO list there http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Install-OS#Mac_OS_X

Alan Taylor (alanvtaylor) added a comment.Via Old WorldAug 12 2012, 10:57 PM

Having looked into the problem a little further: if I go into the original file on the Intel platform, disable the face normal display for all the meshes individually, and re-save, the crashes disappear on the PPC platform.

If this does end up in the wiki, I'll look into fixing this myself (if PPC is no longer supported, would BF entertain receiving a patch here?) - it's probably just a little endianness problem somewhere - shouldn't be too tricky to find.

jens verwiebe (jensverwiebe) added a comment.Via Old WorldAug 13 2012, 12:02 PM

Hi
Does this happen only with own builds ?
I found that in scons and cmake ( cmake i already changed ) there is an endian guessing
which causes wrong endianess flag when compiling ppc on intel !!
Try force big endian by commenting out in sconstruct line 362/363/364 and push back 365
one indent.

Jens

Alan Taylor (alanvtaylor) added a comment.Via Old WorldAug 13 2012, 6:55 PM

Hi Jens,

Thanks very much for looking into this - I see the issue with the official 2.63a release too.

Manually asserting big endian in SConscript didn't change the behaviour though - I suspect the issue is within the source rather than the build configuration. The last couple of crashes I've reported have been fixed by minor data structure redesigns, to avoid some troublesome casts.

Alan

Thomas Dinges (dingto) added a comment.Via Old WorldSep 24 2012, 7:23 PM

Closing, as we officially don't support PPC anymore.

Thomas Dinges (dingto) closed this task as "Invalid".Via Old WorldSep 24 2012, 7:23 PM

Add Comment