Subdivide fails on newly created edge
Closed, ResolvedPublic

Description

I appended an example file. If i open the file, select the two "free vertices", create an edge (F) and immediately call subdivide on it, then the subdivde operator does nothing. If i now deselect the vertices, select them again and use subdivide it works like it should.

Ubuntu 10.10 r49694

niabot (Tobias Oelgarte) set Type to Bug.Via Old WorldAug 18 2012, 5:46 PM

PS: It only occurs in the case if the vertices already exist and are only connected to other edges (not part of a face).

Couldn't confirm this (tried in 2.63a and latest SVN). What version of Blender are you testing?

managed to redo this, but only sometimes (maybe one in 5 times or so), ran in valgrind and its not reporting un-initialized memory.

need to look into this further.

niabot (Tobias Oelgarte) added a comment.Via Old WorldAug 21 2012, 1:23 PM

Notice: This does happen to other operators as well. Just created a circle, selected every nth-vertex and then tried to invert the selection (Strg+I). It did nothing. As soon i left edit mode and entered it again it was working as usual.

apinzonf (Alexander Pinzon) added a comment.Via Old WorldAug 21 2012, 11:09 PM

Couldn't confirm this (tried in blender rev 50102 32 bit, Windows 7).

apinzonf (Alexander Pinzon) added a comment.Via Old WorldAug 21 2012, 11:09 PM

Hi, I can\'t reproduce this here, can you please try again on an
up-to-date SVN revision?

niabot (Tobias Oelgarte) added a comment.Via Old WorldAug 22 2012, 10:53 AM

I can still reproduce it on Ubuntu 10.10 32 bit with r50079 and r50104.

In r49694 i had it every time and with r50079 and r50104 it happens more or less randomly. I just need to extrude two lines (edge->vert->edge->vert->...) and make a connection (edge) in between them. In roughly 50% of the times i have this behavior. The error must be somewhere in the selection code (if the selection is changed by an opertor), because other operators fail as well.

My guess is the following: I can reproduce this bug in multiple ways, but it always involves a first call to operator that updates or changes the selection. Another condition is that none of the selected edges is connected to a face. So i would say that the edge selection status is not rightfully updated after the call to the first operator that changes the selection. The second operator must then see a wrong selection.

niabot (Tobias Oelgarte) added a comment.Via Old WorldAug 22 2012, 1:01 PM

PS: Invert selection seams also to miss some vertices on more complex meshes after i used "Select inner region". The obviously something strange happening inside the selection code.

niabot (Tobias Oelgarte) added a comment.Via Old WorldAug 22 2012, 9:14 PM

I think it gets a really serious issue. Even x-mirror is affected in such cases, not being able to find the mirrored vertex which is exactly at the right place. :(

the newly created edge wasn't selected (only its verts were). fixed r50190.

campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldAug 24 2012, 4:54 PM

Add Comment