Home

cycles: different rendering behavior for GPU and CPU rendering
Closed, InvalidPublic

Description
Hi,

in both official blender builds r46461 and r50064, I get the following problem with the attached simple test file.

I generated a cycles material that does not cast a shadow. This works (ie. there are no shadows from that material) if I render with CPU, but there are shadows (ie it doesn't work) when I render using CUDA.

Please let me know if you need more information about my system. FYI, I asked a few guys on IRC to test the file, and they had the same issues.

Thanks!
dingto (Thomas Dinges) added a comment.Via Old WorldAug 22 2012, 12:37 AM
Hi,
please always mention your computer specifications!

I can't confirm the issue here (Windows 7, nvidia 540) and SVN 50079, most likely you have a old gpu with computing capability < 2.0 and therefore no transparent shadows. That is a hardware limitation and not a bug.

Thomas
metalliandy (Andy Davies) added a comment.Via Old WorldAug 22 2012, 2:22 AM
I cant reproduce this on a 560ti 448 with Windows 7 64bit and r49909. Both images look the same.
tinux (Martin Hoffmann) added a comment.Via Old WorldAug 22 2012, 10:48 AM
Sorry for not mentioning the computer specifications earlier.

The system is a 64bit Linux Mint 13 with

NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)
CUDA 4.2.9
nvidia-driver 304.37

Apparently, this card is capable of cuda compute capability 1.3. I don't know in detail what that means, but it's probably the hardware limitation Thomas Dinges mentioned.

Sorry for the false bug and thanks for looking into this anyway.
brecht (Brecht Van Lommel) added a comment.Via Old WorldAug 22 2012, 12:18 PM
Right, we don't support transparent shadows on this card.
http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering#Missing_Features_with_Shader_Model_1.x
brecht (Brecht Van Lommel) closed this task as "Invalid".Via Old WorldAug 22 2012, 12:18 PM

Add Comment