Closed, InvalidPublic


OS version : MAC OSX 10.8
Blender Version : Official 2.63

Actions (.blend file attached) :
- Add a nurbspath. Add a subdivision surface on it.
- Add and edit a lattice.
- Add a lattice modifier to the nurbspath and activate "show_in_editmode" and "use_apply_on_spline"
- Add an armature with a single bone. Subdivide the bone 10 times.
- Add a spline IK constraint to the tip bone.

Bug : the armature doesn't follow the curve.

Hope this is a bug and not an unsupported feature :D ...

Thank you,

Brecht Van Lommel (brecht) added a comment.Via Old WorldAug 22 2012, 3:38 PM

I fear this is not a bug but a limitation. The subdivision modifier and other "Generate" modifiers don't output a spline but a mesh. The result of such modifiers can be used for rendering, but for things like Spline IK, Taper, Path Follow, .. only the spline up to such a modifier is used.

Brecht Van Lommel (brecht) closed this task as "Invalid".Via Old WorldAug 22 2012, 3:38 PM
Stanislas Paillereau (stanp) added a comment.Via Old WorldAug 22 2012, 4:15 PM

I was afraid of that.
Well, I'm going to look for an alternative solution.

Thanks for looking into it.

Add Comment