language support (input) in text object and text editor
Closed, ResolvedPublic

Description

i cannot write special characters in text editor and text object
i want to write polish letters like ąśćźęłóż but get only question sign "?" in text editor or flipped question sign in text object
i think it is input problem - keyboard mapping or something
when i write this characters in notepad and paste it in blender everything is ok - they appear just fine
to enter special characters i press Left Alt+A for Ą and so on for different letters Alt+E Alt+S Alt+C Alt+Z ...
in earlier version of blender (i dont remember which) everything was ok

ralph rush (camelos) set Type to Bug.Via Old WorldSep 3 2012, 7:05 PM
Brecht Van Lommel (brecht) added a comment.Via Old WorldSep 3 2012, 7:35 PM

Please mention operating system and exact Blender version tested.

ralph rush (camelos) added a comment.Via Old WorldSep 3 2012, 11:24 PM

Blender 2.63.0 r46461:r46487M
and newest at this time from graphicall v 2.63.17 r50351

Windows 7 ultimate x64

ralph rush (camelos) added a comment.Via Old WorldSep 3 2012, 11:32 PM

Windows 7 ultimate x64 polish of corse
and Right ALT+A not left i mentioned before :)

Dalai Felinto (dfelinto) added a comment.Via Old WorldSep 21 2012, 7:42 PM

confirmed the problem in trunk (windows 7, r.50797) - had to add Polish as input language to test it

@Ralph, can you try to pinpoint when this was last working?

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 24 2012, 6:50 PM

Seems this was broken in svn rev43913 which was a fix for http://projects.blender.org/tracker/index.php?func=detail&aid=30044&group_id=9&atid=498

Not actually sure about proper way dealing with both of this issues.

Alex, do you have some thoughts here?

Ton Roosendaal (ton) added a comment.Via Old WorldNov 4 2012, 1:48 PM

Tested in lastest svn, and I type fine with Polish keyboard mapped.
Is this a Windows only issue then?

Ton Roosendaal (ton) added a comment.Via Old WorldNov 4 2012, 2:57 PM

I found a windows error - is in svn now. r51866
Nobody can redo the error or the fix though - windows handles special chars very strange... can any here check?

(It should allow typing alt+key characters)

Sergey Sharybin (sergey) added a comment.Via Old WorldNov 29 2012, 3:31 PM

Ton, it indeed seems to be fixed. Will mark the report as solved for until somebody complains :)

Thanks for the report btw.

Sergey Sharybin (sergey) closed this task as "Resolved".Via Old WorldNov 29 2012, 3:31 PM

Add Comment