Object's diffuse color not showing in Sculpt Mode
Closed, ResolvedPublic

Description

Objects diffuse color is visible in Object Mode while using Solid Viewport Shading, it does not work in Sculpt Mode. 2.63a does work all right, the oldest build I have that shows this bug is r47553.

Roberto Roch Diago (sick) set Type to Bug.Via Old WorldSep 9 2012, 5:51 PM
Sergey Sharybin (sergey) added a comment.Via Old WorldSep 20 2012, 3:20 PM

Would look into this issue.

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 21 2012, 12:15 PM

Developer note:
This is a documented regression since sculpt mask implementation (http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.64/Sculpting#Limitations). Would check whether it's easy to resolve before the release.

Roberto Roch Diago (sick) added a comment.Via Old WorldSep 21 2012, 2:47 PM

I should have read the release notes before posting this, sorry. Thanks for checking this anyway, Sergey.

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 23 2012, 4:17 PM

Well, i've fixed the issue in svn rev50827, so would update release logs :)

Thanks for the report, closing it now.

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 30 2012, 5:07 PM

Unfortunately, something went wrong with this change. Reverted the changes, so 2.64 release would have new feature (which is sculpt masking), with some regressions (which is displaying mask in favor of diffuse color).

We would fix this properly after the release.

Re-opening the report.

Sergey Sharybin (sergey) added a comment.Via Old WorldOct 22 2012, 7:35 PM

Should finally be fixed in svn rev51510 :)

Sergey Sharybin (sergey) closed this task as "Resolved".Via Old WorldOct 22 2012, 7:35 PM

Add Comment