Unusual beeping noise when importing a DAE
Closed, InvalidPublic

Description

Steps to reproduce, in my case:

Load Sketchup, add 3D Text, type something in and align it to centre of the grid there. Delete irritating cardboard human. Export to collada 3D model.

Load Blender 2.6, import mesh -> Collada, load your exported collada mesh.

Listen for beep beep beep, watch as nothing appears.

Issue:
There is absolutely no clue whats up here. The file seems fine. MeshLab, 3D photo studio, Second Life, and a java viewer I've been working on, all seem to load it up just fine and dandy, but Blender 2.6, just beeps like an angry stepchild.

I saw another such report on this, via google, but it's closed because of 'not enough information', I'm hoping you don't close this for the same. As it's Blender that isn't providing enough information for me to actually report. It simply beeps angrily, when you click the import button.

I did, however include an example of the text in the same format thats failing

mont29 (Bastien Montagne) added a comment.Via Old WorldSep 19 2012, 5:38 PM

Have no problem loading the attached file… (debian testing amd64, debug build, r50728).

istormuk (Derek Hollier-Day) added a comment.Via Old WorldSep 19 2012, 6:10 PM

I do, Several. Just bleeps.
Windows 7 Ultimate, Blender 2.6 latest stable release.

Import, and it bleeps.

sergey (Sergey Sharybin) added a comment.Via Old WorldSep 19 2012, 7:28 PM

Gaia, could you look into this issue?

I can import the dae with no issues.
I attached an image of how it looks in my blender (2.63.19, r50699)

Can you please tell the exact version of blender with which you do your tests ?
And please can you provide a screen shot of how the scene looks in Sketchup,
so we can compare it with Blender's import ?

thanks

istormuk (Derek Hollier-Day) added a comment.Via Old WorldSep 19 2012, 8:07 PM

Sure.. One sec.

Not sure it will make a difference, still won't import for me.

I'm aware I can do the same model in Blender. But eh, Sketchup does it in far less polygons than I've managed to pull off with Blender. (Still a blender noob here) I wanted to correct it's materials in Blender, since thats the one skill I DID pick up, but useless til I can actually import, anywho, see attached

Er, trying again, stupid JIRA error

gaiaclary (Gaia Clary) added a comment.Via Old WorldSep 19 2012, 8:17 PM

Hi,

so the image comparison shows me that in principle the import works (for me).

But the more important information is what blender do you use for your tests ?
If you test with an official Blender release up to blender 2.63a,
then please note that the upcoming Blender-2.64 will come with a lot of improvements.

Furthermore please note that we currently have only taken care to improve the Collada export.
I hope that we can get all pending Collada import issues solved with Blender 2.65.

Please also check this page for details about collada status: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#OpenCollada

lockal (Sv. Lockal) added a comment.Via Old WorldSep 19 2012, 10:04 PM

This problem is windows-only.

Type of problem is reading uninitialized memory returned by bc_get_dae_name(mesh). Windows produce bleeps with printf("\a").

It crashes with rc1 in 32-bit XP, maybe Windows 7 just does not crash while reading uninitialized memory.

Unfortunately I cannot provide backtrace with my current setup. However console log looks quite useful (see attachment 032).

gaiaclary (Gaia Clary) added a comment.Via Old WorldSep 19 2012, 10:42 PM

Hi, Sv. Lockal

thank you for your input. However i have debugged the import of the dae file attached to this report and i can not find uninitialised names in it.
I also wonder about your revision number (46591). That must be a Blender 2.63a ? But we are well beyond that meanwhile (the current revision number is 50756) So maybe meanwhile the issue you report has been solved already ?

Please can you provide the .dae file that creates uninitialised names and beeps on Windows XP ? Then i can check what is going on there.

lockal (Sv. Lockal) added a comment.Via Old WorldSep 19 2012, 10:57 PM

Oops, wrong directory brought me back in time for 4000 revisions! No crash or beeps with r50648. Maybe Derek Hollier-Day uses older version, but at this moment everything seems ok.

gaiaclary (Gaia Clary) added a comment.Via Old WorldSep 20 2012, 12:55 PM

Hi, Derek;

Please can you tell us with which exact blender version you have tested this issue ?
You can get the blender version from the Blender splash screen, that opens upon start of Blender

Please can you verify that the problem still exists with the Blender-2.64 release candidates ?
You can get the release candidates from http://download.blender.org/release/Blender2.64/

Thanks

-gaia-

gaiaclary (Gaia Clary) added a comment.Via Old WorldSep 23 2012, 2:37 PM

Hi, Derek;

I will close this report for now.
If you think this is wrong, then please ask for reopening this report
and add which blender version exactly has the problem that you report.

-gaia-

gaiaclary (Gaia Clary) closed this task as "Invalid".Via Old WorldSep 23 2012, 2:37 PM

Add Comment