Home

Crash on "Browse Image to be linked"
Closed, InvalidPublic

Description
Hi, i've got a .blend that contains an imported .obj file.

Every time i click (no matter where) on a "Browse Image to be linked" Button (left from "create new image" or Image Name) Blender Crashes - Abort trap 6. (Console doesn't give more out)

What i (wildly) guess is happening, that the imported Name is not utf-8, and therefore causes Blender to crash? (might be something different, though. But if it is, Blender should convert names to utf-8...)

But what i do know, if i change Textures Names from "C:\Users\Andrew Kramer\Documents\VideoCopilot\Models\My_Models" to whatever it does not crash anymore...

thanks, and have a nice weekend

bashi
Could you try narrow down the filename that causes the crash? - then zip up a file with the name and attach it (copy/paste the name here may change encoding).

Non utf8 names are supported, but this could be windows specific.
in the attached .blend file there are 4 Names that cause the Crash, all of them. Is this .blend not enough? I could zip it.

btw, im on osx (10.7.4)
http://www.pasteall.org/pic/38004

upload on Bug Tracker didn't work.

replace .jpg with .zip
the zip just contains iPhone5.blend which doesnt crash when I browse to it, or within it.

I think the error is more likely a file on your system which has some text blender crashes displaying.

This is hard to know which file it is without debugging directly on your system, but its possible to figure out by moving files out of the directory that crashes.
Posting a reminder that you need to be able to provide information for a developer to redo the bug.

Blender crashing on your computer is obviously bad, but we can't keep reports open that developers don't have enough data to fix.

Realize in this case it means taking time to narrow down the cause of the problem, but in these cases its pretty much unavoidable.
kwk (Konrad Kleine) added a comment.Via Old WorldSep 28 2012, 10:33 PM
Neither can I confirm "the bug". I can select any of the image in the node editor's "Image Texture" node, without blender crashing.

Please try to repeat your problem with one of todays builds of blender. Either problem never existed in blender or it is gone by now.
campbellbarton (Campbell Barton) added a comment.Via Old WorldOct 1 2012, 9:18 AM
closing, bug reports need to be re-producable, if you can find steps to redo this bug - we can re-open.
campbellbarton (Campbell Barton) closed this task as "Invalid".Via Old WorldOct 1 2012, 9:18 AM

Add Comment