Home

NDOF parameters not taken into account
Closed, ResolvedPublic

Description
Since Release 2,64 RC1, the parameters for NDOF devices do not seems to be taken into account, the sensitivity is really high despite the setting of 0,25. The orbit setting does not works, it is always in trackball.

This is encountered with a 3DConnexion spacenavigator device
gdelpu (Gregory DELPU) set Type to Bug.Via Old WorldSep 27 2012, 12:01 AM
brecht (Brecht Van Lommel) added a comment.Via Old WorldSep 27 2012, 5:32 PM
Which operating system are you using to test this?
gdelpu (Gregory DELPU) added a comment.Via Old WorldSep 28 2012, 8:11 AM
I'm using Mas OSX Mountain Lion 10.8.2, by the way I had the same issue with 2.64 RC1, but it works fine in 2.63
brecht (Brecht Van Lommel) added a comment.Via Old WorldSep 28 2012, 2:36 PM
Ah, it seems the sensitivity for rotation and trackball/turntable were decoupled, but the settings were only added to the menu that you get when pressing the "menu" button on. Now they are in the user preferences as well.

I also made them properly convert from the old settings when loading old user preferences, so that the behavior stays the same. Though this may not help you if you already saved the user preferences again, so you might still have to reconfigure the sensitivity/turntable still.
brecht (Brecht Van Lommel) closed this task as "Resolved".Via Old WorldSep 28 2012, 2:36 PM
gdelpu (Gregory DELPU) added a comment.Via Old WorldSep 28 2012, 9:53 PM
OK, but the settings from the users preferences/input menu are useless because they do not affect the NDOF device
brecht (Brecht Van Lommel) added a comment.Via Old WorldSep 29 2012, 2:17 AM
Not sure what you mean ... but perhaps I should have been more clear that I just committed these changes to our development version, and so in the next build you should have settings that do work. Even in the current build you can find the settings when pressing the "menu" button on the device, I just made them available in the user preferences now.
mooncaine (Moon Caine) added a comment.Via Old WorldNov 7 2012, 12:44 AM
I can confirm this with Mac OSX Snow Leopard 10.6.8, blender 2.64.0 51232, SpaceNavigator, with the latest driver, 3dxware beta 10.0.4 (downloaded and installed today, 6 November 2012).

Switching between the Turntable and Trackball NDOF settings doesn't change blender's behavior.
brecht (Brecht Van Lommel) added a comment.Via Old WorldNov 7 2012, 4:17 PM
There's another report about this open, will let Ton investigate it there and keep this closed, because I don't have an NDOF device to test:
http://projects.blender.org/tracker/?func=detail&atid=498&aid=32806&group_id=9

Add Comment