Home

Crash when Exporting to Collada file (.dae)
Closed, ResolvedPublic

Description
Blender crash and exit when I try export ANY project to Collada file (.dae). It always repeated.
My system data:
Windows 7 Home basic,
Radeon HD5145 videocard
Blender 2.64 and Blender 2.63, both.
real-consoler (Andrey Losev) set Type to Bug.Via Old WorldOct 5 2012, 5:38 PM
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 5 2012, 7:50 PM
Gaia, could you please check this report? Thanks!
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 5 2012, 7:57 PM
Please can you be a little more specific ?

I have no troubles with exporting to Collada,
neither on blender 2.63 nor on blender 2.64

Can you provide an example blend file please ?
I did simple object and try it export in .dae. Crash again... For example, no problem export to .3ds others I am not use. I use Google SchetchUp, so I like using .dae formatted
files. Also, assets exported from SchetchUp, when imported in Blender, lost some important parts. It seems only integer objects can be imported from ScetchUp. Not connected objects, but still present in model,are lost in import process...
Simple file I attach here (when I try export it in .dae blender crash again...), hope it will loaded,here little strange system...
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 6 2012, 2:17 PM
I know it\'s frustrating and I don\'t dispute that you have the reported issues.
ut we can not reproduce your issue with the given description and data.
In this bug tracker however, we expect users to present cases that are redoable,
and only then we can work on them.

Here are some hints how you can proceed:

- Try if your issue also occurs on another system ?
- Try to find someone else who can reproduce the same issue ?
- Try to find the common properties of the cases where the problem occurs.
- Provide a step by step description how to reproduce the problem, even if it sounds trivial.
- Provide all used parameters for an action, or tell when you use the defaults.
mano-wii (Germano Cavalcante) added a comment.Via Old WorldOct 8 2012, 2:37 AM
Blender on my computer also crashed when I try to export any collada file to the directory "D: \ Germano \ Acadêmico \ 7 º Periodo \ PLANEJ URBANO E REGIONAL I \ Trabalho da angela \ periodo final \ cotas \".
However when I exported to the "desktop" or drive "C: \" or "D: \" export worked.
Must be because of the "^" and "º" in the directory.
I had a Note Core i3 4GB HD 500GB
real-consoler (Andrey Losev) added a comment.Via Old WorldOct 8 2012, 9:09 AM
I can't use another system, because own just one machine. I no invent any new method to export, just use Blender menu. Wow! I try to save in just drive D: and it works!
It really impossible save in directory, for example like D:/3d/Ferrari project/ferrari-enzo.dae . It look like one similar problem, which just described above by Gemano Cavalcante.
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 8 2012, 9:19 AM
I can confirm that the export crashes when special characters are used in the export path.
real-consoler (Andrey Losev) added a comment.Via Old WorldOct 8 2012, 10:49 AM
What we can do further? Do you resolve this issue yourself? Do you need ,Gaia, something else?
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 8 2012, 3:03 PM
Fix was committed it in revision 51185
Please test the fix and report back if your issue
is not solved.
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 8 2012, 3:03 PM
Your reported issue has been fixed in SVN. Thanks for taking the
time to report!.
gaiaclary (Gaia Clary) closed this task as "Resolved".Via Old WorldOct 8 2012, 3:03 PM
real-consoler (Andrey Losev) added a comment.Via Old WorldOct 8 2012, 5:10 PM
Sorry, I can't find this revision 51185, here is link to https://svn.blender.org/svnroot/bf-blender/trunk/blender/ but there only bf-blender - Revision 51190: /trunk/blender

So where it is? Can you give point where it lies?
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 8 2012, 5:11 PM
You can use any later revision than 51185. 51190 should be fine :)
real-consoler (Andrey Losev) added a comment.Via Old WorldOct 9 2012, 7:21 AM
Ohou...There so much everything,what files I need to take and change for improve export-import? Here still is troubles with others formats... Thank you.
gaiaclary (Gaia Clary) added a comment.Via Old WorldOct 9 2012, 9:22 AM
I do not exactly understand your question. You can get ready made downloads of Blender from Graphicall.org Here is the link for 64bit Windows versions:

http://graphicall.org/64bit/trunk/optimized/blender/windows

Be sure you download a version with revision > 51185.
Right now while i type this post, there are 2 builds which contain the Collada export fix.
real-consoler (Andrey Losev) added a comment.Via Old WorldOct 9 2012, 12:02 PM
Thank you, Gaia. I found later than 51185 svn. It have no russian lang support, but it really not so important, as I can read both eng and ru. Most important, it package
have no import-export Collada .dae. But instead it export TRUE formatted file .3ds, which I also can import in Google SketchUp and work with it. My last Blender version export .dae .3ds files, which loaded in SketchUp with holes(!!!). This version export true file which can be proceed.

But all this still little not useful...

And. I found nothing better than Blender for now. I wish do animations and games and just models, as I am still artist, so Blender really great thing!

Add Comment