Home

Unwanted material stays after Boolean apply
Closed, InvalidPublic

Description
win32, r51271

- notice that filled "window" faces; it's assigned to Walls
- go out Edit Mode; see what happens; this unwanted material also comes out in renders

deleting these faces and extruding edgeloops doesn't help; recalc. normals helps in some cases.

I'm almost sure it's due to that fact I used Intersect mode with a mesh (as a Boolean "cutting" object) with normals that were "inner-directed" so
that gave me forms like extrusions instead of holes (usually with Difference mode of Boolean)
Probably Boolean leaves some mat. ID's after applying that can't be deleted even by deleting those "corrupted"
faces and trying to create a new geometry connected with old (extruding, filling or duplicating).

So I see it's a bug but not isn't crucial (for me). It's not bad but who knows (if I'm right about it's nature) this can cause some another bug.
mont29 (Bastien Montagne) added a comment.Via Old WorldOct 13 2012, 11:53 AM
Will let Sergey decides here, but don’t think this is actually a bug. You are applying boolean modifiers over a non-manifold mesh (i.e. a mesh having edges with more or less than two faces), furthermore ill-formed in some places (like the two "brown" pieces, which should be polygons with six verts each), with some very thin faces here and there… Boolean modifiers just can’t handle such kind of mesh, and they do complain (many FACE LOOP ERROR in blender's console…)!
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 15 2012, 2:01 PM
It's indeed not a bug -- current boolean implementation requires manifold meshes. FACE LOOP ERROR in the console in most cases harmless (just happens when non-manifolds are intersecting).
sergey (Sergey Sharybin) closed this task as "Invalid".Via Old WorldOct 15 2012, 2:01 PM
moolah (Moolah Nasreddin) added a comment.Via Old WorldOct 15 2012, 2:53 PM
Thank you, I got!

Add Comment