Home

2.64 crash opening User Preferences
Closed, ArchivedPublic

Assigned To
None
Priority
Low
Subscribers
None
Author
devbystarlight (Ryan M)
Projects
Type
OpenGL Error
Description
(Note: I realize this is probably an isolated case - ie, something specific to my computer; feel free to contact me for followup)

Hi,

Event:
- Crashes when attempting to open User Preferences
-- Also crashes when trying to open system info... I saw there was a fix posted for that in October 2012

Environment:
- HP laptop (AMD 64-bit)
- Blender 2.63 and 2.64 (oct 2012 distribution)

Reproducibility:
- always

Repro Steps:
# Open Blender
# Click File - User Preferences

Notes:
-- I upgraded from 2.63-264 thinking that might resolve issue
-- Normally using 64-bit Blender ... uninstalled and tried with Blender 32-bit ... same crash
- Tried "Load Factory Settings" (didn't help)


Extra Comments:
A long time ago in an earlier 2.x release (... not sure which version) ... I configured the user preferences for laptop (mouse & numpad emulation, etc).

I upgraded to 2.63 and the User Preferences crash started happening. (I've been working around the crash as best I can in the meantime.)
I saw the new 2.64 release and noticed the "system information" crash was fixed. However, I'm still getting the crash.

Perhaps there is a registry setting which is messed up .. or a bad user preference setting somewhere ... - eg, a stored user preference didn't migrate during a previous upgrade?

I'd be happy to help provide additional info if needed :)

devbystarlight (Ryan M) set Type to OpenGL Error.Via Old WorldOct 16 2012, 6:11 AM
devbystarlight (Ryan M) added a comment.Via Old WorldOct 16 2012, 6:20 AM
Might be related to ... [#32824]
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 16 2012, 12:38 PM
Please always mention video card and operation system you're using. Also having system-info.txt generated by Help -> System Info operation helps a lot.

Does it crash if instead of opening user preferences in new window you're changing editor type from 3D View to User Preferences?

You could also test nightly builds of blender from http://builder.blender.org/download/
devbystarlight (Ryan M) added a comment.Via Old WorldOct 18 2012, 7:16 PM
Hi Sergey :)

- OS: Windows 7 Home Premium
- Video Card: Intel(R) Graphics Media Accelerator HD
-- this is simply the integrated video for the laptop

Setting the view to User Preferences works
- This has been my workaround since 2.63 (instead of File::User Preferences) ... and File::System Info also crashes

However, Help::System Info does work
- I'll attach the file ...
devbystarlight (Ryan M) added a comment.Via Old WorldOct 18 2012, 7:22 PM
Hmmm ... the add attachment reports and Error - missing parameters when I attempt to submit the file. Here are the contents instead:

============================================
= Blender 2.64 (sub 0) System Information =
============================================


Blender:
============================================

version 2.64 (sub 0), revision b'51232'. b'Release'
build date: b'2012-10-09', b'21:33:34'
platform: b'Windows:64bit'
binary path: 'C:\\Apps\\Blender\\blender.exe'
build cflags: b'/nologo /Ob1 /J /W1 /Gd /we4013 /wd4018 /wd4244 /wd4305 /wd4800 /wd4065 /wd4267 /openmp -O2 -DNDEBUG -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWIN64 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -D__LITTLE_ENDIAN__ -DWITH_AUDASPACE'
build cxxflags: b'/nologo /Ob1 /J /W1 /Gd /we4013 /wd4018 /wd4244 /wd4305 /wd4800 /wd4065 /wd4267 /openmp /EHsc -O2 -DNDEBUG -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWIN64 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -D__LITTLE_ENDIAN__ -DWITH_AUDASPACE'
build linkflags: b'/SUBSYSTEM:CONSOLE /MACHINE:X64 /STACK:2097152 /OPT:NOREF /INCREMENTAL:NO /NODEFAULTLIB:msvcrt.lib /NODEFAULTLIB:msvcmrt.lib /NODEFAULTLIB:msvcurt.lib /NODEFAULTLIB:msvcrtd.lib'
build system: b'SCons'

Python:
============================================

version: 3.2 (r32:88445, Mar 2 2011, 16:59:21) [MSC v.1500 64 bit (AMD64)]
paths:
'C:\\Apps\\Blender\\2.64\\scripts\\addons'
'C:\\Apps\\Blender\\2.64\\scripts\\startup'
'C:\\Apps\\Blender\\2.64\\scripts\\modules'
'C:\\Apps\\Blender\\python32.zip'
'C:\\Apps\\Blender\\2.64\\python\\DLLs'
'C:\\Apps\\Blender\\2.64\\python\\lib'
'C:\\Apps\\Blender'
'C:\\Apps\\Blender\\2.64\\scripts\\addons\\modules'
'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\scripts\\addons\\modules'

Directories:
============================================

scripts: ['C:\\Apps\\Blender\\2.64\\scripts', 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\scripts']
user scripts: 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\scripts'
pref scripts: None
datafiles: 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\datafiles\\'
config: 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\config\\'
scripts : 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\scripts\\'
autosave: 'C:\\Users\\Ryan\\AppData\\Roaming\\Blender Foundation\\Blender\\2.64\\autosave\\'
tempdir: 'C:\\tmp\\BlenderTemp\\'

FFmpeg:
============================================

'avcodec':' ''53, 60, 100'
'avdevice':' ''53, 4, 100'
'avformat':' ''53, 31, 100'
'avutil':' ''51, 34, 101'
'swscale':' '' 2, 1, 100'

OpenGL
============================================

renderer: 'Intel(R) Graphics Media Accelerator HD'
vendor: 'Intel'
version: '2.1.0 - Build 8.15.10.1986'
extensions:
'GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color'
'GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint'
'GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp'
'GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod'
'GL_EXT_rescale_normal GL_EXT_packed_pixels'
'GL_EXT_separate_specular_color GL_ARB_multitexture'
'GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate'
'GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add'
'GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add'
'GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays'
'GL_NV_blend_square GL_ARB_texture_compression'
'GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic'
'GL_ARB_texture_border_clamp GL_ARB_point_parameters'
'GL_ARB_texture_env_combine GL_ARB_texture_env_dot3'
'GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc'
'GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs'
'GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle'
'GL_ARB_fragment_program GL_EXT_stencil_two_side'
'GL_ATI_separate_stencil GL_ARB_vertex_buffer_object'
'GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader'
'GL_ARB_shader_objects GL_ARB_shading_language_100'
'GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader'
'GL_NV_texgen_reflection GL_ARB_point_sprite'
'GL_EXT_blend_equation_separate GL_ARB_depth_texture'
'GL_ARB_texture_rectangle GL_ARB_draw_buffers'
'GL_ARB_pixel_buffer_object GL_WIN_swap_hint GL_EXT_framebuffer_object'
'GL_EXT_texture_sRGB GL_ARB_color_buffer_float GL_ARB_half_float_pixel'
'GL_ARB_texture_float GL_NV_conditional_render GL_EXT_texture_swizzle'
'GL_ARB_draw_instanced '
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 18 2012, 8:31 PM
Moved from Blender 2.6 Bug Tracker to OpenGL errors
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 18 2012, 8:31 PM
This is likely bug in inte'ls driver we can not resolve.

Coyple of things you could do to verify this:

- Switch editor type from 3D viewport to user Preferences and see if Blender will crash (intel's driver crashes on opening new window)
- Download opengl32.dll from http://download.blender.org/ftp/incoming/softwaregl/ and put it to the same directory as blender.exe, start blender after this. This library will switch blender to fully software OpenGL and issues with drivers shouldn't affect on blender
- Check for driver's update at intel's download center
devbystarlight (Ryan M) added a comment.Via Old WorldOct 18 2012, 8:52 PM
- Switching the view from 3D to User Preferences works okay

- Intel says my drivers are up to date

- I downloaded the opengl32.dll ... and it works

... however, Blender becomes unreasonably slow (unusably slow) ... which makes sense without any hardware rendering benefits.

Conclusion:
- Appears this is a bug with my Intel video driver
- I will simply continue to avoid using the File:UserPreferences :)
- (I won't be using software rendering unless I have problems elsewhere opening a critical window in Blender)

Thank you for looking into this!
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 19 2012, 12:05 PM
Yeah, unfortunately, it's indeed intel's driver bug. Probably it could be worked around from our side, but it's really tricky to do without having buggy setup.

You could also try downgrading driver, maybe it'll help. And indeed, for now simply use single window configuration.

Thanks for the report anyway. Will close the report now.
sergey (Sergey Sharybin) closed this task as "Archived".Via Old WorldOct 19 2012, 12:05 PM
jessechisholm (Jesse Chisholm) added a comment.Via Old WorldOct 15 2013, 11:21 PM
I accept that you cannot address every bug in every version of every display driver.
I even accept that this issue is caused by a bug in the display driver.

What I wonder is:
* what does User Preferences do that no other aspect of Blender does that causes this driver bug to crash the app?
* is there any manual way to edit the User Preferences without using the GUI?

-Jesse

PS: I have the latest drivers (2009) from Acer (manufacturer) and Intel (chipset) and the issue persists.
(: Yes, this is an old laptop :)
jessechisholm (Jesse Chisholm) added a comment.Via Old WorldOct 15 2013, 11:34 PM
WORKAROUND:
Click the "Editor Type" button of your #D View area, then select "User Preferences".

PS: What does "File / User Preferences" do that "Editor Type / User Preferences" does not so?

-Jesse

Add Comment