Motion Blur not working on GPU
Closed, ResolvedPublic

Description

Duplicates: T33058

It crashes everytime, whatever the scene, , even in viewport, F12 and CTRL-F12 rendering...Works with CPU only

I tried to return with FACTORY Settings but sames result...

Tried with versions 51365, 51374 of TUNGERS and ALB3530 from graphicall. ( apparently buildbots versions doesn't include obj motion blur still... )

Tested on Win64, 2xGTX 580 driver 306.90 -> i tried with only 1 GTX580 active, but it still crash...


Vincent PARIS (vipvip24) set Type to Bug.Via Old WorldOct 17 2012, 8:43 AM
Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 17 2012, 9:13 AM

for info, i just tried the same blender on another computer with 1 GTS450, and it seems to work... ( win 64 too, drivers 296, but the 296 drivers make cycles crash with one or two GTX580 )

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 17 2012, 9:53 AM

THird test: on win 64, with one GTX470 and drivers 306.23 : it crashes...

Sebastian Michailidis (okapi) added a comment.Via Old WorldOct 17 2012, 11:50 AM

I am experiencing the exact same issure.

Windows 7 64bits
GTX 570+GTX580

Tobias Oelgarte (niabot) added a comment.Via Old WorldOct 17 2012, 12:50 PM

Does not crash on me under:

Ubuntu 12.04 64 bit
GTX 560 TI (304.51)
Blender r51376

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 17 2012, 12:56 PM

just installed the 51380 build of Mikkah, but still it crashes...

Falk Müller (xharthok) added a comment.Via Old WorldOct 17 2012, 3:58 PM

Same issue here. Crashes when trying to render with GPU in Viewport or F12 rendering. Tested on multiple Blenderversions 32 and 64bit.

Console output:

CUDA error: Unknown error in cuCtxSynchronize()
CUDA error: Unknown error in cuGraphicsMapResources(1, &pmem.cuPBOresource, 0)
CUDA error: Unknown error in cuGraphicsResourceGetMappedPointer(&buffer, &bytes,
pmem.cuPBOresource)
CUDA error: Unknown error in cuModuleGetFunction(&cuFilmConvert, cuModule, "kern
el_cuda_tonemap")
CUDA error: Unknown error in cuParamSetv(cuFilmConvert, offset, &d_rgba, sizeof(
d_rgba))
CUDA error: Unknown error in cuParamSetv(cuFilmConvert, offset, &d_buffer, sizeo
f(d_buffer))
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.sample)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.resolution)

CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.x)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.y)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.w)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.h)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.offset)
CUDA error: Unknown error in cuParamSeti(cuFilmConvert, offset, task.stride)
CUDA error: Unknown error in cuParamSetSize(cuFilmConvert, offset)


Windows Vista 64 bit
GTX 580 (tested drivers 301.42 and 306.97)

Thomas Dinges (dingto) added a comment.Via Old WorldOct 17 2012, 4:49 PM

Looks like a sm_20 only issue atm, assigning to Brecht.

Carsten (calli) added a comment.Via Old WorldOct 17 2012, 5:32 PM

Same here. It was after Revision: 51384 I think.

For me it crashed while loading the cuda kernel first. Now on every render.

XUbuntu 10.04 64bit.

OpenGL
============================================

renderer: 'GeForce GTX 460/PCIe/SSE2'
vendor: 'NVIDIA Corporation'
version: '4.2.0 NVIDIA 295.53'

Brecht Van Lommel (brecht) added a comment.Via Old WorldOct 18 2012, 12:48 AM

Been trying to fix this all day, but no luck yet. I did do a commit now where it hopefully runs again, but there will be no motion blur on sm 2.0 still.

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 18 2012, 6:06 AM

thanks brecht for following it.
Just tried the ALB build v51395 from graphicall and it works, with object motion blur (!!) on my 2 x gtx580 workstation: and it is fastest than i expected:
As usual, congrats for your impressive job !

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 18 2012, 11:21 AM

Just tried the ALB build v51395 with my notebook, CUDA and GTX525M drivers 306.23 : it crashes...

Krantz Geoffroy (kgeogeo) added a comment.Via Old WorldOct 18 2012, 2:41 PM

last svn
ubuntu 12.04 64.
3GB NVIDIA GeForce GT 555M

exact same output as Falk Müller:
CUDA error: Launch failed in cuCtxSynchronize()
CUDA error: Launch failed in cuGraphicsMapResources(1, &pmem.cuPBOresource, 0)
CUDA error: Launch failed in cuGraphicsResourceGetMappedPointer(&buffer, &bytes, pmem.cuPBOresource)
CUDA error: Launch failed in cuModuleGetFunction(&cuFilmConvert, cuModule, "kernel_cuda_tonemap")
CUDA error: Launch failed in cuParamSetv(cuFilmConvert, offset, &d_rgba, sizeof(d_rgba))
CUDA error: Launch failed in cuParamSetv(cuFilmConvert, offset, &d_buffer, sizeof(d_buffer))
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.sample)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.resolution)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.x)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.y)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.w)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.h)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.offset)
CUDA error: Launch failed in cuParamSeti(cuFilmConvert, offset, task.stride)
CUDA error: Launch failed in cuParamSetSize(cuFilmConvert, offset)

Brecht Van Lommel (brecht) added a comment.Via Old WorldOct 18 2012, 2:54 PM

I did some more fixes, did not check for the right cuda version. Still can't get motion blur to work on this card myself, it might need cuda 5.0, will keep trying.

tung ster (tungster) added a comment.Via Old WorldOct 18 2012, 4:29 PM

Brecht, I'm adding the error here 'cause I think it may be related, by involving the nvcuda.dll
He did'nt say what was going on when the crash happened.

Reported from Elias79 on my graphicall build = Win7.x64 r51396
"Also crashes :(

Problem signature:
Problem Event Name: APPCRASH
Application Name: blender.exe
Application Version: 2.6.4.0
Application Timestamp: 507ffa90
Fault Module Name: nvcuda.dll
Fault Module Version: 8.17.13.142
Fault Module Timestamp: 4fb2030d
Exception Code: c0000005
Exception Offset: 000000000004844e
OS Version: 6.1.7601.2.1.0.256.4
Locale ID: 1033
Additional Information 1: d2e2
Additional Information 2: d2e2945599f2f26d3701df484995b6f0
Additional Information 3: ce90
Additional Information 4: ce90a776de2e531e2b65cf015cd77fb0

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt "
Cheers,
~Tung

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 18 2012, 7:05 PM

for info, the motion blur was working very well on the 51395 build, but is not active on the 51407 version of graphicall ( but no crash of cycles ).
Still talking about CUDA GPU rendering with 2 x GTX580

Falk Müller (xharthok) added a comment.Via Old WorldOct 18 2012, 11:49 PM

Confirmed, motionblur on GPU is working with the ALB build v51395 from graphicall. That's the only version that works with MB and GPU on my system.

Windows Vista 64 bit
GTX 580 (driver 306.97)

Brecht Van Lommel (brecht) added a comment.Via Old WorldOct 19 2012, 12:55 AM

Yes, I disabled motion blur on sm 2.0 for now. It works with CUDA 5.0 (after enabling it in the code), maybe that's the cuda version that graphicall build is using. Not sure yet I want to make 5.0 a requirement, or if I can find a solution to make it work with 4.2.

Vincent PARIS (vipvip24) added a comment.Via Old WorldOct 19 2012, 5:07 AM

trieied teh last alb-version of graphicall (51411) and motion blur is disabled too...

Sebastian Michailidis (okapi) added a comment.Via Old WorldOct 20 2012, 4:47 PM

Blender does not crash anymore on me but now I get artifacts when turning on motion blur: https://dl.dropbox.com/u/675429/motionblurbug.jpg
The shader looks weird, too. Same image with motion blur turned off: https://dl.dropbox.com/u/675429/motionblurbug_nomoblur.jpg

Sebastian Michailidis (okapi) added a comment.Via Old WorldOct 20 2012, 4:49 PM

Sorry, I forgot to mention the build: r51444
r51396 works perfectly fine btw. No artifacts and motion blur looks the way it is supposed to.

Thomas Dinges (dingto) added a comment.Via Old WorldNov 3 2012, 11:31 AM

Closed duplicate report [#33058] No object motion blur with GPU

Brecht Van Lommel (brecht) added a comment.Via Old WorldNov 29 2012, 1:43 AM

Fix in svn, thanks all for the testing and reports.

Brecht Van Lommel (brecht) closed this task as "Resolved".Via Old WorldNov 29 2012, 1:43 AM

Add Comment