Child Object Origin Snap and Mirror Problem
Closed, ResolvedPublic

Description

Blender 2.64a 64-bit
Windows 7 Ultimate 64-bit
Intel Core I5-2500K
8 GB RAM
Intel HD 3000 Graphic Card


Actually, maybe this is not a bug, but interesting and an unwanted situation.

If one object has an parent object and parent object is translate, rotate, scale etc. then, "Origin to 3D Cursor" command (and others) and "Object > Mirror" command not works properly. If "Apply" transformations for parent, then this commands works properly.

See attached blend file.

ton (Ton Roosendaal) added a comment.Via Old WorldOct 27 2012, 6:02 PM

- Mirror on transformed objects always is wacko, that's a math issue with trying to reconstuct location, rotation and size from a 4x4 matrix. It's an open issue for which we don't have answers (if that even is possible)

- The 'origin to cursor' is buggy indeed. There's a whole lot of code trying to solve cases - unfortunately the coder of it isn't around anymore.
Let's see if someone dares to pick this up!

spiderh (Hikmet Koyuncu) added a comment.Via Old WorldOct 27 2012, 7:38 PM

Thanks.

Maybe in future, pivot points translate like an object (example 3ds Max's "Pivot Only" command). This is pretty easy way for tanslate pivot (origin) point.

artificer (Ben Batt) added a comment.Via Old WorldNov 4 2012, 3:08 AM

I have fixed the "Origin to 3D Cursor" issue (it was just using the wrong matrix to transform the origin offset), but am having trouble attaching a patch, so it's at http://pastebin.com/RwEgfCZ0 .

artificer (Ben Batt) added a comment.Via Old WorldNov 4 2012, 3:10 AM

Hmm, looks like the attachment worked despite the error message, so never mind the pastebin thing!

ton (Ton Roosendaal) added a comment.Via Old WorldNov 4 2012, 1:34 PM

In svn now, thanks Ben! Welcome back :)

ton (Ton Roosendaal) closed this task as "Resolved".Via Old WorldNov 4 2012, 1:34 PM

Add Comment