Home

Keyframes in the Animated Influence field don't respond.
Closed, ArchivedPublic

Description
The Animated Influence property of the action strip can be keyed and an f curve is created but the action strip doesn't respond to the keyframes. In the attached blend file, the horsewalk action strip is overridden by the lockFeet action. The animated influence of the lockFeet strip is 1 between frames 209 and 219 amd then goes to 0 at frame 222 to allow the horseWalk action to control the feet again. The graph editor shows the correct values just described but the animated influence doesn't respond.

Specs:

Blender 2.64.0 r51035 64 bit for windows 64.
Intel i5 laptop.
ton (Ton Roosendaal) added a comment.Via Old WorldOct 31 2012, 1:03 PM
Hi Eric,

Joshua is still busy with other work. I am not familiar with this code, but could give it an attempt.
However - I would need your help for this first. SInce you fully understand the error, it would be far more optimal if you could create the simplest possible blender file that shows the error. That saves me a lot of time trying to disect your .blend file back to an error I don't fully grasp even :)
ericsh6 (eric hall) added a comment.Via Old WorldNov 2 2012, 7:19 PM
Hi Ton,

Sorry for taking so long to get back. I attached a very simple model of a cube that has to NLA strips. The lower strip moves the cube along the X axis from 0 to 100 frames and the upper strip moves the cube the same except it is at higher Z value for illustration purposes.

The upper strip the "Animated Influence" box checked. I selected the upper strip and pressed "TAB" to enter strip edit mode and I keyframed the influence from "0" at frame 30 to "1" at frame 50 and back to "0" at frame 70. So the box should gradually move in positive Z between frame 30 and 50 and then go back down.

But the "animated influence" is ignored in or out of strip edit mode. You can see the keyframes but they don't respond.

Incidentally, I did try right clicking on the upper action strip without going into edit mode and checking the "animated influence" box and inserting keyframes. This creates keyframes above the upper action strip that don't seem to be associated with the cube but this case does work. Perhaps this is the way it was intended to work. But I believe the action strip should control it's own influence.

I can start a thread in the animation forum to see if this is supposed to be like this.
ton (Ton Roosendaal) added a comment.Via Old WorldNov 3 2012, 1:58 PM
Hi Eric,

Thanks for the example.

I confirm the strange display on "editmode strip" in NLA - there it inserts influence keys, but they don't do anything.
That might well be a bug - the editmode was meant to expose the action contents internally.

Without editmode strip, influence key inserting works - sorta, i get confusing results sometimes.

My main concern: I totally fail on adding NLA strips in Blender - with default startups. Just insert keys on a cube, and try to add a strip in NLA. How do you manage this?
aligorith (Joshua Leung) added a comment.Via Old WorldNov 6 2012, 12:32 AM
Unfortunately, this case really falls more into the TODO category (by definition).

The original intention here was that NLA strips were able to have one or two dedicated F-Curves for controlling their evaluation time and influence. However, managing to override the UI insert/delete key mechanisms for this case was a bit difficult (not to mention, problematic due to lack of way to display in other anim editors). So, there were a few unsolved issues there.

I'm kindof surprised that the Durian team even managed to get this working for their shots.
ton (Ton Roosendaal) added a comment.Via Old WorldNov 6 2012, 10:13 AM
How do I add an NLA strip on default startup cube? All the code I checked keeps returning zeros because there are no tracks yet.
ton (Ton Roosendaal) added a comment.Via Old WorldNov 8 2012, 6:21 PM
Oh - you have to press the 'snowflake' icon!

I will make a note on this for the NLA todo in wiki:
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Animation
ton (Ton Roosendaal) closed this task as "Archived".Via Old WorldNov 8 2012, 6:21 PM
I have done some more experimenting with the animated influence. In the simple example I just attached (animated_influence_3.blend) I have, for example, 2 action strips and select one of them (but not edit it - so the action strip is yellow) and over in the properties box on the right I check the "animated influence" box. So I enter in an influence value for that strip and right-click and create a keyframe. A keyframe appears in the NLA editor in the track above the action strips and in the action editor. If I then right-click select another action strip and create a keyframe the same way another keyframe is added to above both action strips and the action editor shows that I now have keyframes on both strips. I can click on the "star" symbol in the NLA and turn the "action influence" keyframes into an action strip. This is very cool and I'm sure this is how the action influence was designed to work. So I don't think now there is a bug but I still think the action strip should be able to store it's own keyframes otherwise you have to keep tabbing out of an action strip to change it's "action influence" in the track above which is not very interactive way of blending actions. But I agree that his should be moved to the "to-do" area. I should have done more homework before submitting this as a bug.

Add Comment