Home

Decimate generates overlapping faces on flat surfaces
Closed, ResolvedPublic

Description
As of r51725 (msvc win 64, daily buildbot) the Decimate modifier will generate lots of thin long overlapping triangles if used on a large flat grid-like surface (such as the result you get from the Remesh modifier).

To reproduce:
Remesh default cube (octree depth 7 is fine), apply
Add decimate modifier (Collapse, 0.1 ratio is fine)

Test .blend attached

Note old Decimate modifier also generated overlapping triangles, but results weren't quite as severe.
Hi, I checked on 2 fixes for this.

One is to prevent collapsing edges that would result in flipped faces. (see file attached).
This mostly works but there are still islands of uncollapsed faces and it doesnt really work great (ofcourse possible error in my test too, but think this isnt practical).

Another option which I found worked best is to jitter the vertex locations a little before collapsing, but this is also a bit of a weak solution.

It would be nice to support this, but this is more of a todo item since the previous decimate modifier also had this problem.

Also, we have planer-decimator option which behaves better for this example.

Set as TODO: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Decimate_Modifier
Looked into this further and committed a fix r51990.

closing.
campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldNov 7 2012, 11:44 PM

Add Comment