Page MenuHome

Blender 2.64 crashes on startup
Open, NormalPublic

Description

Duplicates: T33072

I'm running Windows XP Home SP3.
Graphics card: NVidia GeForce GTS450.

Blender 2.63 runs just fine.
When I try to run 2.64 or 2.64a, I get the following message:

Runtime Error!
Program: C:\...\blender.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

No .blend file is necessary. It crashes on start up.

Details

Type
Bug

Event Timeline

This is not much information... but we had a similar report pointing at the Python.dll in our distro:
http://projects.blender.org/tracker/?func=detail&atid=498&aid=33066&group_id=9

I will reopen the other one, and link this report there.

Note that we can only fix bugs if there are ways for a developer to redo the problem... it's the reporter's job to investigate how :)

Ton Roosendaal (ton) closed this task as Invalid.Nov 4 2012, 12:38 PM

Hi,

The other report was most likely not related to your crash - but you could check.

Also check on our bug reporting guidelines;
- try other versions of blender (did it ever run?)
- is your graphics ok for a heavy opengl app like blender?
- test it on another computer to compare

Thank you, Ton.
It does seem that Python is related to my crash. The console window says the following (the caret is pointing to the comma):

found bundled python: C:\Program Files\Blender Foundation\BlenderOld\2.64\python

Fatal Python error: Py_Initialize: unable to load the file system codec
File "C:\Programs\PYTHON26\LIB\encodings\__init__.py", line 123
raise CodecRegistryError,\
^
SyntaxError: invalid syntax

Just a note. After seeing the other bug report, I tried installing the newer version of Python (2.73), but that didn't help. I get the same error message as above but pointing to the new Python location.

And to quickly answer your other questions:
Yes, earlier versions of Blender run just fine for me. Every version up to 2.63 I have had no problem with and I've been using it for years.
Yes, my graphics card is OK for a heavy OpenGL app like Blender. NVidia GeForce GTS450.
I don't have another computer immediately handy to test with. Sorry.

Joseph, why did you try Python 2.x? Blender works only with Python 3.2.

OK. I've found the problem.
This (and probably 33072) is related to issue 31506.
If you have an external Python install, and the PYTHONPATH system variable is set to point to that, then Blender will use the external Python build which is incompatible and causes the crash.

Thanks for your help in sorting this out. I have to say, for a free program, this is pretty excellent customer service!

Ah. I wasn't aware of that.
Thank you Shinsuke.

Hi I do have the Same Problem the output looks like this:

C:\Users\Wasi>"C:\Program Files\Blender Foundation\Blender\blender.exe"
found bundled python: C:\Program Files\Blender Foundation\Blender\2.67\python
Fatal Python error: Py_Initialize: unable to load the file system codec
File "C:\GitStack\python\lib\encodings\__init__.py", line 123
raise CodecRegistryError,\
^
SyntaxError: invalid syntax

To change the PYTHONPATH is no option to me because this variable is used by an other program.

This is actually a bug and it is not fixed.
I had to delete my PYTHONPATH variable to make it work.
I don't know if it's hard for the startup script to ignore environment variable if python version is 2.
I am using the latest version of Blender (2.70 currently).
I think the issue should be reopened.

The root cause of this problem is that a different version of Python exists on the Windows system (probably 2.6 or 2.7).

I fixed this on my Windows installation by creating a Blender,bat file (windows batch file) in the blender-2.71-windows64 directory, with the following contents:

set PYTHONPATH=""
blender

Hope this helps someone!

I'm having this problem but don't know how to resolve it, I need to set the "PYTHONPATH =" but have no idea how to

I HAVE THE SOLUTION

It worked for me.

Download the newest python version.
Locate you python and you blender path.
3.Go to YOUBLENDERPATH/YOURBLENDERVERSION.

4.There should be a folder called python.

Make a copy of that folder.
Copy you WHOLE Python Folder(That you have downloaded/installed) into the YOUBLENDERPATH/YOURBLENDERVERSION folder.
Blender should work now.

I know this is old, but I wanted to provide an alternate solution to those who do not wish to remove their PYTHONPATH environment variable. I am on version 2.75a and this solves my crash on startup issue.

  1. Make a batch file somewhere like your desktop
    • To do so, create a blank .txt document and name it blender.bat (MAKE SURE THE EXTENSION IS .bat and not .txt)
  2. Edit blender.bat and add the text below

INCLUDE EVERYTHING BELOW (NOT THIS LINE)

set PYTHONPATH=""
cd C:\Program Files\Blender Foundation\Blender\
start blender.exe

INCLUDE EVERYTHING ABOVE (NOT THIS LINE)

  1. Your blender path may be different, so make sure you find the correct path
  2. run blender.bat

This will temporarily set the PYTHONPATH to "" (nothing) during your blender session but is restored after you close.

@Aaron Levey (aaron) Great solution! Fixed my crash on startup.

Gökhan (POI-OEZD) reopened this task as Open.May 15 2018, 2:31 PM

The above solutions didn't help me. I still get the found bundled python error and the blender window freezes on startup with just the sillhoutes visible....