Home

Deactivating position and rotation from IK-solver crashes Blender (ITaSC)
Closed, ResolvedPublic

Description
I appended an example file with a selected bone that has an IK constraint. Since I'm using iTaSC i can deactivate "rotation" and "position" in the constraint panel. The problem is that Blender will always crash if i deselect both options (both on = fine, one on = fine, both of = crash). I can't reproduce this error with a more simple scenario. It seams to happen when two IK-Constraints deform the same chain (tree ik).
niabot (Tobias Oelgarte) added a comment.Via Old WorldNov 14 2012, 9:37 PM
PS: iTaSC also behaves strangely. I would expect the bone behind (parent) the selected bone to move if i move one of the red bones to the left or right. But it shows no rotation at all. This might be the reason for the crash as well or both influence each other.
niabot (Tobias Oelgarte) added a comment.Via Old WorldNov 14 2012, 9:40 PM
Tried some more. The chain is always only as long as the shortest "chain length". In my example "seil-b" has a chain length of 3 and "plattform" has 1. Both together result in a chain length of 2 for "seil-b". That means that the IK constraint from "seil-b" has no influence on it's third bone "seil-a".
ben2610 (Benoit Bolsee) added a comment.Via Old WorldDec 5 2012, 11:07 PM
thanks for the sample file. I can reproduce the crash and I see where it's happening in the code. Will fix that soon.

Regarding the chain length issue, this is a known limitation. See this comment in the code:
// Oh oh, there is already a chain starting from this channel and our chain is longer...
// Should handle this by moving the previous chain up to the beginning of our chain
// For now we just stop here
It is easy to work around this limitation: just make sure that all overlapping constraints have consistent chain length (i.e. use the same root bone) and iTaSC will behave as expected.
ben2610 (Benoit Bolsee) added a comment.Via Old WorldDec 6 2012, 11:25 PM
Fix the crash in revision 52803
dingto (Thomas Dinges) added a comment.Via Old WorldJan 20 2013, 5:56 PM
Closing this report as it has been fixed.
dingto (Thomas Dinges) closed this task as "Resolved".Via Old WorldJan 20 2013, 5:56 PM

Add Comment