New Bevel wrong behavior
Closed, ResolvedPublic

Description

The attached picture shows it all actually. I was just playing around with the new bevel tool, and when tried to bevel the selected edges as shown in the picture, got that strange result...

Brecht Van Lommel (brecht) added a comment.Via Old WorldDec 12 2012, 6:47 AM

Please always attach a .blend file to the report, and mention the exact Blender version tested.

Howard Trickey (howardt) added a comment.Via Old WorldDec 12 2012, 1:28 PM

Is the problem you see that the bevel edges have uneven width? I can't tell without a blend, since it could just be perspective distortion, but the bevels do look uneven.
If so, this is probably a known problem with the current bevel. In some cases it is impossible to have the same width bevel on all edges and have them meet at their meeting points. This is geometry, not something that can be programmed around and "fixed". But it should be possible (in most cases) to have at least a consistent bevel width across any particular edge, and the current code doesn't ensure that. It's something I'm thinking about how to fix, but it isn't easy.

Brecht is right. Sorry for not giving you guys enough information...I'm using Blender 2.65.0 r52859 and the .blend file is now attached.

Howard, bevels are uneven as as you see in the picture, there's no perspective distortion. It indeed looks like a tricky situation to deal with the support edges at the sides. But it got my attention as in 3dsmax this case works just fine, even though it's bevel is such a crap compared to this new blender one. I hope you can figure a way to make this work consistently...

Regards,
Eugenio

Yes the support edges seems to be confusing the bevel, i tried on my end to reproduce your geometry but without the supporting edges, and the bevel works correctly, it's only if i add the support edges that the bevel will go bad as in your screenshot :
while the support edges in the bottom of the structure are pushed correctly inside the face, the support edges of the top of the structure are pushed out of the face, generating the bad result at those corners

Attached the comparative screenshot "bevelgood.jpg" and "bevelbad.jpg" if what i mention is not understandable with my poor english.

Howard Trickey (howardt) added a comment.Via Old WorldFeb 1 2013, 1:11 PM

I looked at this some more, and attached a simpler .blend file that is the pre-bevel geometry that exposes the problem.
This is not easy to fix because the behavior that I think users expect here results in an edge polygon that is not just a rectangle but instead is a concave polygon. Which is likely to render poorly. So I'm not sure whether or how to fix this. I'll think about it some more.

I think this was fixed with commit 9a78cda. But the original model wasn't loaded into the bug so I can't be sure. Can krisaor please check with a build after this commit (submitted Fri Nov 15 10:19 EST) to see if it is fixed?

Howard Trickey (howardt) closed this task as "Resolved".Via WebNov 28 2013, 4:17 AM

I am closing this bug, as I believe it is fixed. If you want to reopen, please attach a .blend file that exhibits a problem.

Add Comment