particle systems of type emitter got wrong rotation if random rotation above .1
Closed, ArchivedPublic

Description

Problem : With some random rotation values, rendering is buggy (cycles and BI, windows and linux)
Changing the emission number sometime resolve the problem.
Blender 53377

Steps : Default scene, add a plane, on that plane a particle system with the cube as rendering object. Make the cube smaller on a side to see the orientation bug.
Render, all is ok.
Now activate rotation and change the random value under "velocity/hair" so that it is above 0.1 , render again, most of the cubes are invisible and with wrong rotation.

Example file : I did a file for better understanding, just render, it will be wrong, increment number of emission and rerender, all will be fine.

Ton Roosendaal (ton) added a comment.Via Old WorldDec 30 2012, 7:11 PM

I find our particle system quite confusing :)

The demo file does do unpredictable things, but there's a couple of things:
- you have set display percentage to 1. In Blender internal it ignores that, in cycles not - thats a bug.
- the particles get generated on random positions
- so if you change particle emission by 1, all particles get different positions and orientations.
- orientations only work relative to previous frames, if you step through frames backwards things mess up.

But further - I can't figure out in this example what the rotation bug is...

mat ali (mat_ali) added a comment.Via Old WorldDec 30 2012, 11:26 PM

Thanks for the answer,
I couldn't reproduce the rotation bug with simple cubes. I can't post the original file because of rights and file size is huge anyway. But i post some renders of it.
Only difference between the 2 renders is that i incremented the emmision number of +1, which made the bug disappear.
in bug.jpg, all particles are in the same wrong direction, no more randomisation. I didn't find any logic in that bug appearing or not, it's very random. However, most of the time it comes from changing the random rotation value.

Ton Roosendaal (ton) added a comment.Via Old WorldDec 31 2012, 11:23 AM

The simpler the file you provide the better. In your example too many things go on, so I cannot see what the issue is really.
Random locations of particles, combined with random rotations, combined with frame stepping, etc... note that particle rotations can only work on 2nd frames or more.

mat ali (mat_ali) added a comment.Via Old WorldDec 31 2012, 1:13 PM

After an hour of try to get the bug on a simple scene, i had no success. But the bug still hapen on the grass scene (with very complex setup, i tried to modify many things, but sometime modifying a parameter "activate" the bug and sometime, modifying the same parameter does not activate it... so it's hard to find the source.

From my many test 2 things came out to be sure :
- Viewport preview is always good, rotations are correct, amount of particles too.
- Deactivating physics solves the problem, but it's not animated anymore :(
- When the bug comes in rendered mode, all particles "jump" = slightly translated on the Z (normal ?) axis in the viewport.
- Increasing the emission number of +1 before rendering solves the bug too, visible in viewport too as all particles come back to emitter (revert that jump). So my workflow is : change particle system parameters, increase emission number, render.

I will try to find the source of the problem in a simple file, but it is not simple.

ok, another hour of try and succeed, whoa it will start to be a full time job to hunt bug ^^

New file attached very simple :
Factory settings, default scene, add a plane, part system on it, cube as render object.
Activate random rotation under "velocity/hair".

Note : Only works in random or jittered emission, grid is ok (after switching to grid, if you revert back to random or jittered, change the random rotation slightly to reactivate the bug)

Ton Roosendaal (ton) added a comment.Via Old WorldFeb 16 2013, 6:07 PM

Collecting all particle rotation errors here (4 already):
http://projects.blender.org/tracker/index.php?func=detail&aid=32340&group_id=9&atid=498

Sorry, but for time being this feature is not in maintenance.

Ton Roosendaal (ton) closed this task as "Archived".Via Old WorldFeb 16 2013, 6:07 PM

Add Comment