Home

Cycles render + Fog Glow node at High
Closed, ResolvedPublic

Description
If I render with the regular blender render everything is ok, but if I render the same nodes(FogGlow High) with cycles render, the second the node is aplyed, I get a big square full of weird pixel. But if I lower it to Medium, everything is ok.

Sorry for my english,


Blender 2.65a 64bit zip format
Windows 7 64bit
8 G DDR2 kingston
CPU Q9400 Intel
MoBo: DQ45CB
Asus nvidia GTX 550 Ti 1G DDR5

JF
cdog (Filip Sauer) added a comment.Via Old WorldJan 1 2013, 1:15 PM
It actually works for me. I can't see any problem. I rendered on CPU and tried in the compositor with OpenCL and withtout it and it made no change.

blender 2.65a
Win 7 64 bit
i7 Q 720
MD Radeon HD 5600
jft_quebec (Jean-Francois Tasse) added a comment.Via Old WorldJan 1 2013, 4:39 PM
Sorry I forgot to say that in cycles render, I used cuda.
jft_quebec (Jean-Francois Tasse) added a comment.Via Old WorldJan 1 2013, 6:26 PM
I made the test with cycles render and I used my cpu instead of cuda and I have no problem. So is it safe to say that the problem is probably leaning towards cuda?
brecht (Brecht Van Lommel) added a comment.Via Old WorldJan 2 2013, 1:13 PM
I can redo the problem here, there is a very bright specular highlight which is causing issues with floating point precision. Cycles is pretty poor at sampling this too, it's actually planned to solve this particular case for 2.66 with multiple importance sampling. A workaround is to change the Glossy node to use the Sharp distribution which will keep the material reflective but the specular highlight from the lamp will not show up.

Even if Cycles is poor at sampling this, ideally it should not give extremely big values that cause issues in compositing, so I'll have to investigate why that happens.
brecht (Brecht Van Lommel) added a comment.Via Old WorldJan 14 2013, 6:55 PM
This should be fixed now with the multiple importance sampling for lamps, rather than fireflies it now shows the area light in the reflection.
brecht (Brecht Van Lommel) closed this task as "Resolved".Via Old WorldJan 14 2013, 6:55 PM

Add Comment