Shadows produce artefacts in vertex colour baking
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
Ubuntu 12.04
NVIDIA Corporation G94 [GeForce 9600 GT] (rev a1)

--- Blender version with error, and version that worked ---
2.65.3 r53494 (first revision with vertex colour baking)

--- Short description of error ---
Some vertices are erroneously marked as shadowed when baking to vertex colours. The affected vertices changes between two sets each time the bake is run.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
The attached .blend file contains an object with baked shadows. Grease pencil circles show the locations of the artefacts. Initially, two artefacts are visible: one on the back of the head, and the other on the left ear. If it is baked again (press Bake in the render buttons), two other artefacts appear instead of the original two. If it is baked again, the original two artefacts appear again.

z0r (Alex Fraser) added a comment.Via Old WorldJan 2 2013, 1:38 AM

Taking this for myself, since vcol baking was my patch.

But Brecht, if you have any ideas please let me know :-)

fixed r54014.

campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldJan 23 2013, 4:02 AM
z0r (Alex Fraser) added a comment.Via Old WorldJan 23 2013, 1:11 PM

Whoa, thanks for fixing this! That's the kind of thing I had intended to do, but I failed on my first attempt. I think I was shifting the coordinates along the face instead of away from it - which I thought might work because the rasterised UV bakes don't seem to suffer from it.

Anyway, thanks :)

Add Comment