Home

Incorecct UV mapping from camera view
Closed, ResolvedPublic

Description
--- WIndows 7 , quadro 600 ---


--- Blender version with error - 2.65 , and version that worked - all previous


--- In previous versions, being in camera view and mapping 'project from view' object with texture same as background tex, gave perfect math both of them.
but in 2.65 something goes wrong. mapping dont fit to backgroud.
I came to this that this bug only presents on non square textures. With square tex ex. 512x512px everything is correct. ---


--- Create Grid, give a material with non square image texture, set the same texture as background.
Go to camera view, enter edit mode of grid, U > 'project from view.' ---


campbellbarton (Campbell Barton) added a comment.Via Old WorldJan 4 2013, 9:15 AM
This isnt a bug, there is an option to correct from the image aspect or not.

The problem is that this option isn't displayed in the toolbar because of the context check the toolbar uses doesnt include the 3d-view region.

Leaving this open since I think it should be resolved, but for now you can press F6 to change the options..
cenobi (Jakub Strykowski) added a comment.Via Old WorldJan 4 2013, 9:30 AM
Ohh.. I didnt know about that. Thanks for tip. Hope this appears in toolbar in future.
fixed r54203.

Settings display in the toolbar now.
campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldJan 30 2013, 12:06 PM
mooncaine (Moon Caine) added a comment.Via Old WorldMar 5 2013, 11:02 PM
Where is this 'toolbar'? Do you mean the Tool Shelf that shows when I press the letter "t"?

Reason I ask: I keep UV mapping an image to a mesh, and the rendered object's texture is not lined up the way it is in the UV/Image editor window. I moved the vertices, lined it up, but the image always looks smaller on the object when it renders. Both image and mesh are square.

If you could point us to a link in the online docs, that'd be great. It'll probably have the answer to my question, above. If not, can we get a screenshot of the toolbar and that button?

Thanks!
mooncaine (Moon Caine) added a comment.Via Old WorldMar 5 2013, 11:24 PM
Updating: I found the answer to my UV problem (unrelated). Hope I caught you before you wasted time on my request... and thanks again!
ton (Ton Roosendaal) added a comment.Via Old WorldApr 19 2013, 5:53 PM
Campbell changed default for this, so it will work as expected if you project from camera.
The toolbar is 't key' panels yes :)

Add Comment