Multiple textures on a mesh not showing in object mode for muti or single texture rendering.
Closed, ResolvedPublic

Description

They do, however, display properly in object mode when GLSL rendering is selected (not a practical option on real maps because of the number of sampler units required).

They do show properly in edit mode for all three display modes. Of course, everything works fine when rendered.

I have attached a simple .blend consisting of a single object with two "brushes"*, each with a different textures. The sun lamp is so the textures can be seen in GLSL mode.

* quake mapping term for convex polyhedron.

Carsten (calli) added a comment.Via Old WorldJan 10 2013, 11:47 AM

Confirmed. It is not in 2.65a but in Trunk from today.

Also in "Texture Solid" Mode only the first UV is shown in Viewport.

Sergey Sharybin (sergey) added a comment.Via Old WorldJan 10 2013, 12:11 PM

Please always follow report bug guidelines and provide information about your operation system, graphics card and exact blender version you're using.

Couldnt' confirm the issue using current trunk and 2.65a release on linux 64bit.

64bit Linux (debian sid), nvidia G80 [GeForce 8800 GTS] using nouveau, svn blender (current as of this update).

Load the attached .blend. In object mode, both walls have the same texture (blood splattered cobble stones). In edit mode, the upper wall is clean "metal".

PS, I've attached screen shots taken with the gl-render button.

Sergey Sharybin (sergey) added a comment.Via Old WorldJan 11 2013, 8:59 AM

Ah, could see the issue now. Happens only if VBOs enabled. Looking into fix :)

Issue is caused by changed draw_tface__set_draw in svn rev53116 which now doesn't set texture from tface. Attached patch seems to be solving this particular issue, but i'm not sure which exact object color issue Brecht was fixing in that revision so would want him to doublecheck on this change.

The patch causes a segfault.

Brecht Van Lommel (brecht) added a comment.Via Old WorldJan 11 2013, 11:56 PM

The fix looks correct to me and works ok here on OS X / NVidia 9600 GT.

I'm not sure what would be causing the crash with Nouveau drivers, that's not clear to me from looking at the code, might need to test on a Linux system to find out.

Brecht Van Lommel (brecht) added a comment.Via Old WorldJan 15 2013, 12:02 PM

I've committed the fix anyway, the code looks ok to me and isn't very different from what it was doing before. Could you verify if it still crashes when using the official buildbot here?
http://builder.blender.org/download/

Brecht Van Lommel (brecht) closed this task as "Resolved".Via Old WorldJan 15 2013, 12:02 PM
Bill Currie (taniwha) added a comment.Via Old WorldJan 15 2013, 1:09 PM

Sorry, I forgot to post that the crash turned out to be some weirdness with my nouveau installation. It works very well now.

Brecht Van Lommel (brecht) added a comment.Via Old WorldJan 15 2013, 1:48 PM

Ok, thanks or testing.

Add Comment