Home

rendering a particle system with emitter increase file size
Closed, InvalidPublic

Description
--- Operating System, Graphics card ---
Linux and Windows, intel GMA

--- Blender version with error, and version that worked ---
error in r53476, couldn't find a working version

--- Short description of error ---
File size increase after each render that follow a particle system modification.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Open attached blend (default scene with a plan with particles on it), it's some Kb big.
hit F12 (you can cancel after it starts rendering),
save again, the file is many Mb big.
Every time the emission number is changed, then a render happen, the file size increase.

Note : Even setting the emission number to 1 (so the scene is a just containing a plane with 2 cubes) doesn't resolve the problem.

mat_ali (mat ali) added a comment.Via Old WorldJan 3 2013, 1:48 PM
After furher testing, setting the emission number value back to 1 help if a render is done before saving.
On simple scene it's ok. But on big scenes where the steps before rendering start take time (1 min on my computer on my current project) it makes saving really slow or huge.
I made a script in the mean time that set all emission numbers for all particle system back to 1, render then reset the values to what they were and save. Thus, files are small, save can be fast and loading is fast. But as I said, on heavy scene the rendering can be very slow, thus making save take more than a minute.
sergey (Sergey Sharybin) added a comment.Via Old WorldJan 9 2013, 2:31 PM
Issue is caused by the fact that all particles data is saved to .blend file. Before you render, particles are not generated at all, so there'll be small file size. Once you started rendering (or enabled viewport display of particles) they'll be generated and saved to .blend file.

Not sure if it's possible to avoid saving ParticleData to .blend file with current design.
ton (Ton Roosendaal) added a comment.Via Old WorldJan 10 2013, 4:35 PM
Particle caches were always saved in the past (pre 2.5 too), but they have been growing in size enormously.
Also if you add fur to characters, things grow very fast.

It's a bit "sign of the times" too, more memory, bigger disks, faster computers... we can only try to be careful here.

On the positive side: we want to look into Alembic support once, which has excellent support for compressing animation point data.
ton (Ton Roosendaal) closed this task as "Invalid".Via Old WorldJan 10 2013, 4:35 PM
sergey (Sergey Sharybin) added a comment.Via Old WorldJan 10 2013, 4:40 PM
Ton, what's really annoying here is that it's not just a point cache in this case. If you'll use external case file size will grow up after adding particles as well. As i understand, it's current state of all particles (ParticlesData structure, contains current size, position, some other stuff -- total 200 bytes) per single particle will be saved to .blend fiel anyway. When you've got thousands of particles it affects on size dramatically.

But i would agree solving disk usage would need some complete fresh decision here.

Add Comment