Hiding curve segments has erratic behaviour.
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
Vista, GTX470

--- Blender version with error, and version that worked ---
r53413,

--- Short description of error ---
- If hiding curve segment in edit mode, it's normals are still displayed (BezierCurve.005).
- Hidden curve segments remain hidden when exiting edit mode. Might be a feature not a bug, but it makes it really hard to select the curve if for some reason all the curve was hidden and edit mode exited (BezierCurve.005).
- On some curves hiding works only for nodes(vertices), segments remain visible (BezierCurve.006).
- If starting node(vertex) of a curve is hidden select All/None doesn't work anymore (in edit mode).

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
See the error section.

Ton Roosendaal (ton) added a comment.Via Old WorldJan 3 2013, 7:47 PM

Seems to be very old code here, can check on it.

Ton Roosendaal (ton) added a comment.Via Old WorldJan 15 2013, 4:42 PM

Fixes are in svn now, thanks for reminding this old todo :)

- normals are not being drawn for hidden curves
- even worse: Blender also didn't hide the extrusions or bevels for hidden curves
- outside edit mode, it shows all (as for all other modes)
- (de)select-all now works when 1st (or any) handle was hidden.

Ton Roosendaal (ton) closed this task as "Resolved".Via Old WorldJan 15 2013, 4:42 PM

Add Comment