Page MenuHome

OSL image crash on Windows 8
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
Windows 8, i7 720-qm, radeon 5650m, 4gb ram


--- Blender version with error, and version that worked ---
2.65a

--- Short description of error ---
Rendering a scene using any image texture while using OSL in cycles crashes

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Change the render method to cycles, enable osl rendering and simply add an image texture as the color of any shader. Now try to render and ta-da!

Details

Type
Bug

Event Timeline

Several people tried, but all failed to get errors.

The request for a .blend file (+ image in your case) is really for a good reason. If OSL would fail on such basic cases we wouldn't have released it even.
So there's something going on for you, for which we need your help first to pin it down. Getting errors reproduced on other systems is a crucial first step.

OK Ton here are the .blend file and the texture, please note that in my pc even by trying to add an image texture to the default cube and trying to render with osl activated crashes blender.

I could not confirm a crash with this file, nor with the mentioned default cube + texture.
I tested official Blender 2.65a and current SVN build on Windows 7 x64. (64 bi builds).

Either it's a Windows 8 issue or only happening on your system.

You sure use the official build from blender.org? Please try a new one from the buildbot: http://builder.blender.org/download/

Yes I was using the official build. Today I downloaded blender-2.65-r53766-win64 from builder.blender.org, and I get the same crash. so I think it is very possible that the problem is something with my pc's configuration. Tomorrow I will give it a try with my job's pc to see if the results are any different (which by your comments is very possible).

Thanks guys.

By the way do the shield look any good?

Ok got it working without a problem in a Windows 7 Ultimate x64 machine with an i7-2600, 8gb ram, and no dedicated gpu, so, is it my pc or might it be a windows 8 related problem?

It's likely related to the operating system rather than any particular hardware setup, I'll try to get this investigated on Windows 8.

I can confirm the crash on Windows 8, not sure yet what's going on there, still have to set up a build environment to investigate it.

Great!, Thanks Bretch, keep up the great work!

Fix in svn now, was a bug in LLVM. This fix will not be in the first 2.66 testbuild but should show up in later builds.

Brecht Van Lommel (brecht) closed this task as Resolved.Feb 6 2013, 8:59 PM

Great Brecht, thank you very much, I really appreciate it! Oh, and sorry for misspelling your name the last time.