Page MenuHome

Icosphere invisible in wireframe view if subdivs 6+
Closed, ArchivedPublic

Description

--- Operating System, Graphics card ---
Windows 7 64bit
Radeon HD6950

--- Blender version with error---
Error in r53922 and release 2.65

--- Short description of error ---
Icosphere is invisible in viewport while in wireframe object view, if icosphere subdivision are 6 or greater.

Reproduce:
1 : add icosphere with 6 or greater subdivisions
2 : switch to wireframe view, icosphere cannot be seen



Details

Type
To Do

Event Timeline

This is a limitation of edge draw optimization which is based on angles between edges. If subdiv level is high, angle between edges is small and they're getting skipped. It's known limitation of this optimizer and you could work it around by enabling "Draw All Edges" in Object settings.

Thanks for the report, but would not consider this is a bug, more like a thing to be improved.

Sergey Sharybin (sergey) closed this task as Archived.Jan 21 2013, 10:18 AM

A by default completly invisible object is somewhat strange, I would say.
Since "Draw All Edges" is a "per Object Setting", couldn't this setting be changed in a way that drawing all edges is the default ?
And then make a checkbox for "Hide Low Face Angle Edges" in the Object Settings instead.
Perhaps even better, if this settings could be set globally/for all objects too, in the N-Panel under Display, e.g.
Then one could make this his individual default.

Greetings

We are planning to bump viewport to a completely new level, here edges drawing wouldn't be such a problem. So don't think it'll be a good idea to change defaults now.