Can't Scroll in User Preferences when opening with Shortcut
Closed, ResolvedPublic

Description

--- Win7 64bit Quadro FX 2700M---


--- Blender 2.66 RC1---


When opening User Preferences Window from File menu,everything is OK. However, when using Ctrl Alt U to open it, I just can't scroll the interface up/down by the scrollbar(s). Quite strange. No file attached, since that's so obvious. FYI.

(Works fine with official 2.66 Testbuild1)

Same problem

--- Blender 2.66 RC1 ---

--- Found same problem in test build ---
--- Found same problem in latest builds at builder.blender.org ---

I can confirm the problem here. Also clicking on the arrows on number buttons doesn't work correctly, it's like you're ctrl+clicking it then. So probably the ctrl+alt modifier keys are somehow stuck.

Problem caused by this commit: http://projects.blender.org/scm/viewvc.php?view=rev&root=bf-blender&revision=54450

This works on X11 but evidentially not windows, r54450 rB48f905d806254eebe66ddbdba8e63266977e63e3 reverted this commit, closing.

Campbell Barton (campbellbarton) changed the task status from Invalid to Resolved.May 20 2014, 6:24 AM

Will fire up my Windows machine the next days to investigate this.

@Hadrien Brissaud (hadrien), re your comment in rBcb023ce0fd1a0cd0, I tried a few things but wasn't able to reproduce. Are you sure it does happen using latest master (please test with buildbot)? If so, please make sure the UserPref window is active while you try to scroll (although I doubt this to be the issue - just want to be sure).

@Leon Cheung (leon_cheung), @Campbell Barton (campbellbarton), are you able to reproduce on Win?

Julian Eisel (Severin) lowered the priority of this task from Normal to Incomplete.Feb 28 2015, 4:51 PM

Just tested with latest build, I cannot reproduce it either. Probably ressolved already?

@Julian Eisel (Severin) the issue I reported still happens on my machine but this one doesn't - I don't encounter any issues when scrolling in userprefs window (opened with ctrl+alt+u)... are these related ?

Julian Eisel (Severin) closed this task as Resolved.Mar 5 2015, 6:40 PM

Did you create a separate report for whatever still happens for you or do you just mean the comment you added to rBcb023ce0fd1a0c? As this commit aimes to fix the report here, they are related. So if you encounter any other issues than reported here, you should better create a new bug report.

Anyway, seems like it wasn't needed to reopen this so back to Resolved :)

Sorry for confusion, I just meant : latest master does not solve rBcb023ce0fd1a0c.

Well that I understood. The question is what does not work for you and how can others recreate it? So as I said, better open a new report so we can investigate it deeper.