Page MenuHome

UI: Mouse lag and displacement - Windows8 Nvidia driver error
Closed, ArchivedPublic

Description

--- Operating System, Graphics card ---
- Windows 8 Pro
- GTX460 Nvidia


--- Blender version with error, and version that worked ---

- Release 2.66 - Bug appeared
- Unsure of last good version - had latest 2.65 on this workstation. Also tried 2.66 on another, Win7 workstation and have not seen this bug.


--- Short description of error ---

Two parts:

A) The mouse click point seems to be offset from the mouse cursor location. For instance, the 3D cursor appears in a different place than where you click - nearby the mouse, but not where the mouse is. This includes the menu system and attempting to click on a vertex.

B) There is lag (or the perception of lag) as if the actual mouse point is attempting to catch up with the cursor, but never quite does. I.e., pull a menu down, see the highlight line offset from where the mouse is. It follows, but doesn't catch the mouse. When you click it does sometimes register where the mouse pointer is, but will still have another line highlighted

The end result is that 2.66 is completely unusable on Win 8. This could be a driver or mouse rendering problem. I did update nvidia drivers to the latest reference drivers a few days before the Blender release, although this has never been problem before. Blender seems to work okay when you can select what you want. Also, the startup time is very long compared to every other Blender release. Are these Win8 specific problems?

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

1) Start up blender, look at time to start up and if there is a gray screen for several seconds
2) Attempt to select something through the menu system, such as "help">"Splash screen". Watch for mouse offset problems. It should be almost impossible to get the splash screen to pop up and stay up, even with the menu line highlights properly
3) Tab into the default cube. Attempt to right click a vertex and move it (this is be harder than usual) - hit "esc" and notice the vertex stays where the mouse pointer was instead of cancelling out the move
4) Left mouse click around - observe 3D curse out of sync with the mouse. The off distance increases as the mouse moves faster.

Details

Type
OpenGL Error

Event Timeline

Nobody (None) closed this task as Archived.Feb 23 2013, 7:33 PM

Same Problem:
Windows 8 Pro 64bit
NVidia GeForce GT 540M
Driver 314.07

It is not happening with 2.66 RC.

Steps:

Have one object select. Select another, and screen is not refreshed, although the second object seems to be selected. Select a third object and then the second is highlighted. Looks like the viewport is refreshed after the subsequent mouse operation.

This can be noted also for vertex selection, drop down lists and even tooltips.

This thread in BA indicates a problem with driver version 314.07.

http://blenderartists.org/forum/showthread.php?282677-2-66-Viewport-problems

Moved from Blender 2.6 Bug Tracker to OpenGL errors

Yeah, this error is Windows8 driver related.
It should be affecting Blender 2.65a too then though.

Moving to ogl issue tracker with clear title. It's very unfortunate - but with our 100% cross platform code base there's no choice for us.

Try reverting to 310.90 version of Nvidia driver. It fixed similar behavior for me.

Was having this same issue with windows 8 Pro 64 bits. Upgraded to BETA driver 314.21 and issue appears to have been resolved.

I also had this error, and while this method is a bit... blaraghrgahr. It works for me.

When you try to place the 3dcursor you get this "lag" that makes it look like everything is one step behind. At least sort of.
What I did, is that i minimized the window, and then maximized it again, and then it worked for some strange reason. Hope it works for you guys as well.